PDA

View Full Version : Cannot mount USB hard disk



chiefnz
28-09-2011, 10:09 AM
Hi guys,

as per title I have a 2TB Western Digital 2.5" USB drive which is not being assigned a drive letter (not being mounted) by Windows.... When Windows asks to intialise the disk I get the following error message...

"Media write protected"

I have tried to use EASUS Data Recovery wizard to see if I can restore the partition/data to another disk but after 14 hours this was unsuccessful as nothing was found... I'm assuming this is because the disk is write protected so DRW could collate the file/partition information correctly.

I'm busy at work and haven't had any time to GOOGLE any of this as yet...

Anyone got ideas as to how to remove the write protect status and then hopefully mount the disk.

Cheers,

1101
28-09-2011, 10:53 AM
a few questions
has this drive ever worked ??
have you tried in another PC?
Is it a brand name USB Drive, or a generic case with a drive put inside it ?

Speedy Gonzales
28-09-2011, 11:00 AM
You could try one of these. (http://www.tomshardware.com/forum/265839-32-external-shows-disk-management-initilized) Is there anything on it? One site says a virus may also cause that message

chiefnz
28-09-2011, 11:25 AM
a few questions
has this drive ever worked ??
have you tried in another PC?
Is it a brand name USB Drive, or a generic case with a drive put inside it ?

Yes it has worked before.
Yes I have tried it in a desktop andlaptop and the result is the same.
Yes as per post, it is a branded disk...WD Elements Portable SE (I have checked the model and it is a 500GB disk, even though Windows is reportig it has 2TB)


You could try one of these. (http://www.tomshardware.com/forum/265839-32-external-shows-disk-management-initilized) Is there anything on it? One site says a virus may also cause that message
Yes there is data on it which I need to retrieve.
Looked at those solutions but no joy.

Thanks,

Speedy Gonzales
28-09-2011, 11:26 AM
Is it on the mobo in your sig?

chiefnz
28-09-2011, 11:34 AM
No it's currently plugged into an HP 6730b notebook.

Speedy Gonzales
28-09-2011, 11:40 AM
So what was it initialised / formatted on originally?? Is it a SATA (Is it SATA) 2 or 3 hdd? And what version of windows is on the notebook?

1101
28-09-2011, 11:43 AM
my suggestion.
Its now a data recovery. Attempt it yourself or seriously consider taking it to a tech or Data Forensics($800+)

Remove it from the USB case & attach to the PC via sata cable
If youre lucky it will then work. Else run data recovery software on it

edit:just re-read your 1st post.
some recovery software works better than others. Havnt tried Easus
Getdataback is very good for data recovery. They may have a demo to see if it will see any data
before you buy it.
But it has to come out of the case, you'll need to break it open.
Also see if there are any known firmware issues with the actual HD.

Speedy Gonzales
28-09-2011, 11:47 AM
I could try and use a few data recovery programs, if you want. Soon find out if any will work

chiefnz
28-09-2011, 12:54 PM
It's a WD disk, and is not SATA/SATA2, it has some sort of WD custom internal connection. So connecting the physical disk directly to another computers data interface bypassing the oringal case/cable is not going to work.

I think the primary issue here is that without initialising the disk, data recovery software is unlikely to work. I will try others 1st though before throwing in the towel.

Keep the ideas coming for now.

Thanks,

Speedy Gonzales
28-09-2011, 01:08 PM
You'll be surprised what data recovery programs can do. I've recovered data from a memory card, windows couldnt even see it. But I got all the data off it then formatted it

1101
28-09-2011, 02:03 PM
Sometimes, if Win will has a hissy fit (tech term) & refuses to mount the drive..use Linux
Lin will sometimes mount the Win partition when Win refuses. (to obvious?)

or
Paragon Disk Copy is a bootable CD(Lin based I think) that can copy directories from one usb HD to another. Worth a try, free versions were(are?) available.

chiefnz
29-09-2011, 09:40 AM
Haven't been able to do much more on this issue. I have tried a few Disk recovery tools but no joy as yet. Anyone have more software recommendations to try on this. Linux also failed to initialise/mount the disk?

Speedy Gonzales
29-09-2011, 10:05 AM
Does this enclosure or whatever it is have some kind of write-protect switch on it. According to some sites some do

1101
29-09-2011, 12:07 PM
this will help, will not be easy .:groan: :groan:

http://www.datarecoverytools.co.uk/2010/05/05/how-to-connect-and-recover-usb-only-western-digital-drives-with-hd-doctor-suite/

http://www.forensicfocus.com/index.php?name=Forums&file=viewtopic&t=7248&postdays=0&postorder=asc&start=0

just gotta love use of non standard connectors
WD tech dept, "what can we do with this drive to p*ss everyone off & make data recovery harder"
:badpc::badpc:

Twelvevolts
24-10-2011, 06:50 PM
Ok this thread sounds awfully like what I am expereincing with newly purchased WD 750 gig drive.

It worked and I was watching an episode of Dexter off it on to my laptop. Unfortunately I accidentally disconnected and then it wouldn't start up again.

Doesn't show up at all in the Windows 7 Computer view, can see it as a 2 terrabyte drive in storage management, as an unallocated space.

Attempts to initialize it receive a "media is write protected" message. Acronis Disk Director can see the drive but can't seemingly do anything with it.

General Tab in Device Properties says the "device is working properly".

Have tried to remove the write protect in regedit - doesn't work.

I don't need to recover data, have tried to format the drive so far without success.

Will try some of the ideas above - any further ideas welcome.

kahawai chaser
24-10-2011, 07:42 PM
Search the WD knowledge base, (http://wdc.custhelp.com/app/answers/detail/a_id/1708/p/228,219,329/c/130/session/L3RpbWUvMTMxOTQ0MTQ5MC9zaWQveXpFbGxsSGs%3D) they mention drivers as possible issue, and show compatibility for various operating systems and WD units. Can download if required.

Twelvevolts
24-10-2011, 10:36 PM
Tried all of the WD tools before I posted and nothing seemed to work.