PDA

View Full Version : no sound from HDMI from GeForce GTX 550 Ti card



kiwibits
18-09-2011, 01:37 PM
I've just installed a nvidia GeForce GTX 550 Ti card which has HDMI output. I've connected it to my TV. At first i got picture and sound but now only picture. What I've changed is previously I got video/sound via composite connections from my old card to the tv and it worked fine. I connected the HDMI to the tv and everything worked fine so I pulled out the old composite cables, pluged the HDMi cable into a more convenient plug now pic but no sound. I still get sound on the computer ok. I'm running winXPpro, there is no dedicated sound card on the computer and I have no other HDMI devise to test the cable on. Any help appreciated. One other thing is the cable is 10 meters long but the picture is good with no problems

Speedy Gonzales
18-09-2011, 01:47 PM
Does it have a SPDIF header on the card?? If it does it needs to be connected to the SPDIF header on the mobo. Altho, not all videcards with HDMI have this header.

kiwibits
18-09-2011, 01:54 PM
Does it have a SPDIF header on the card?? If it does it needs to be connected to the SPDIF header on the mobo. Altho, not all videcards with HDMI have this header.

Sorry but in English a dummy can understand?
the card is one of these
http://www.evga.com/articles/00618/

ta

Speedy Gonzales
18-09-2011, 01:57 PM
Does it have 2 or 4 pins on it, if it does it needs a SPDIF cable. That link doesnt show anything thats on it like pins

kiwibits
18-09-2011, 02:09 PM
does what have 2 or 4 pins? where am I looking?

Speedy Gonzales
18-09-2011, 02:13 PM
On the card. And the mobo will have to have a SPDIF header on it somewhere. Thats what you plug it into. Read the manual for both

feersumendjinn
18-09-2011, 02:27 PM
Hdmi (http://en.wikipedia.org/wiki/HDMI) has the sound and video incorporated in the one plug/socket (no separate cables needed).
Is more likely that you need to turn on your output through your speaker properties (r-click the (white (in W7)) speaker icon RH side of your taskbar, and L-click Playback Devices in that menu).
Or might be included in your video card config page (as well?), cant tell you for sure, I dont have a HDMI capable card.

Speedy Gonzales
18-09-2011, 02:31 PM
The HDMI cable may give you sound, but some cards have headers (and on the mobo) that you have to connect (from the mobo to the videocard) so sound will work. Others (like this you dont need anything else but the HDMI cable)

kiwibits
18-09-2011, 03:12 PM
No sign of anywhere to plug in anything extar to the video card. Nothing about them in the instructions (yes I did read them and nothing fell off)
There's no 'Playback Devices' option in win XP
would removing the old composite cables have made any difference or can i forget that option.

feersumendjinn
18-09-2011, 05:41 PM
In Xp, right-click grey speaker icon in taskbar, left-click Open Volume Control in that menu, left-click Options then Properties, there are your playback (and recording) device volume control options.
Also try Adjust Audio Properties from that same taskbar menu.

Or might be included in your video card properties/configuration page (as well?), cant tell you for sure, I dont have a HDMI capable card.
And did you check this?

1101
19-09-2011, 12:43 PM
Been through this myself
Some of the older cards, the HDMI audio never worked properly (if at all) . Some had the 2 connectors for dig audio on the card, some had none, some had the connectors but werent labled or mentioned in the manuals(so could actually have been for anything)
Some of these older cards also wouldnt interface very well with HDMI TV's
I had to replace my card with a newer one to get HDMI working correctly.

If its a newer, then it will have audio chip 'built into' the vid card. This will need the audio driver installed for that vid card (yes it does). Download & install the newest driver from Nvidia.

kiwibits
19-09-2011, 01:04 PM
I finally managed it resetting from 'clone mod' to 'indipendent mod' so HDCP would work then I changed the settings in the audio part of the nvidia card settings to 'nvidia high def audio' and it works!! ie I played with everything till something worked. Of course I now have no sound on the computer speakers but resetting is no problem now I know how and I guess I'll just push more buttons till something happens.
Ta for all the help, always appreciated