PDA

View Full Version : Windows 7 HomeGroup Grief



johcar
26-06-2011, 12:34 PM
I now have two (three when my daughter returns from university in the holidays) other machines in the house that are running Windows 7 apart from my laptop.

I seem to be having great difficulty in making HomeGroup work. I have a HomeGroup instance created on my laptop (it was the first Win7 machine in the house), but when I try to link the other machines to it, they fail to connect (I can see all the machine names in Explorer under the "Network" icon).

I have run the Troubleshooter on my machine and it has reported "Your machine administrator has disabled Teredo locally. Contact your machine administrator."

I have contacted my machine administrator (me) and he's just damn useless. :D

The Google results don't seem to be of much help either...

The home network consists of a PC, to which a ADSL modem / router is attached (Thomson TG585 v7 - yes, I know, a piece of crap), and two laptops, one of which is connected wirelessly and the other (mine) which is both wired and wireless - usually wired, though.

The other two machines are running Win7 Home Premium and mine is running Win7 Ultimate.

All thoroughly up-to-date.

(There's also a TiVo in that connection group, wirelessly connected, plus a couple of smartphones - but I wouldn't imagine they will have any bearing on the current issue)

So after all that, I guess my question is, how do I enable Teredo?

johcar
26-06-2011, 12:39 PM
Is this (http://www.sevenforums.com/network-sharing/59793-teredo-missing.html)relevant:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Tcpip6\Parameters\
Add a DWORD, DisabledComponents with a value 0xffffffff, this disables all IPv6 components. Restart the computer now edit 0xffffffff to 0. This enables IPv6.

Speedy Gonzales
26-06-2011, 12:40 PM
Enable IPv6 under their adapters. Since, HG uses it

wainuitech
26-06-2011, 12:40 PM
From what I understand, Teredo is part of IPv6, so if your hardwares not capable it wont work.

HomeGroup is a PITA anyway -- better to disable it, make sure all computers are on the same workgroup, and use the standard networking.

In W7 , just make sure network discovery and sharing is enabled, and password protected sharing is disabled.

click start , type in sharing select manage advanced sharing, and work through the settings.

johcar
26-06-2011, 01:06 PM
Cheers - the last setting "HomeGroup connections" - should I select the "Use user accounts blah, blah" option rather than the "Allow Windows blah, blah" setting?

johcar
26-06-2011, 01:11 PM
Enable IPv6 under their adapters. Since, HG uses it

When I go to Local Area Connection Properties IPv6 is already enabled...

wainuitech
26-06-2011, 05:00 PM
Cheers - the last setting "HomeGroup connections" - should I select the "Use user accounts blah, blah" option rather than the "Allow Windows blah, blah" setting? If you are going to use standard networking - take a look at my settings -- never have any problems sharing on any PC thats connected as long as they are on the same workgroup. Sharing setup (http://www.imagef1.net.nz/upload/Sharing.jpg) The password protected sharing is the one that trips up most people, with it off you wont get prompted to enter user names and passwords.

mcginty
27-06-2011, 09:10 AM
Check the dates and time on the computers, I recently experienced problems with Homegroup when the clock was 12 hours off.

Chilling_Silence
27-06-2011, 09:20 AM
I'm with wainuitech, I've found Homegroup to be more of a PITA than it's worth. It was a nice theory, but the execution is poor to say the least.

Just setup the same User Account (Both with identical passwords) on all machines. Call it 'homegroupuser' if you really want. Then, when file-sharing between machines, set it to remember the 'homegroupuser' password as your credentials ;-)

Empathy.
27-06-2011, 01:13 PM
Yeah, seconding wainuitech.. Well thirding I guess.. Workgroups are simple :D

jinja_thom
27-06-2011, 06:23 PM
Hi johcar,
My home network is a workgroup mainly because I use 5 different Operating systems so a homegroup is not relevant, but after reading this thread I thought I would try a homegroup for the experience. So I fired up my win7 laptop and it took just a few key strokes to get it up and running in a homegroup with the win7 PC, so it does work.

In the properties of your network adapters on each of the win7 systems does it show IPv6 as installed and selected (tick in the box) if it does then it is IMHO your router that cannot handle the protocol. I use a D-Link Dl-624 wireless router as the Lan connection point.

Chilling_Silence
27-06-2011, 11:00 PM
It *can* work in the right circumstances, but a lot more could have been done to make it more interoperable etc.

IPv6 support on the router has nothing to do with it, as I can get it working, and my router doesn't support it, but it's not *perfect*, and not reliable.
The router will just be acting as a switch, unless it's routing the "homegroup" out the internet connection (Which you wouldn't want) ;)

johcar
28-06-2011, 12:31 AM
Thanks for your help everyone - actually got it working using the instructions I found here:

http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/how-can-i-install-homegroups-in-windows-7-when/4865cd00-4ed9-4407-83eb-4babd99bf1e3

jinja_thom
28-06-2011, 01:23 AM
Have a look at this http://support.microsoft.com/kb/929852

I found it here http://www.howtogeek.com/forum/topic/how-do-i-enable-the-microsoft-6to4-adapter-in-windows-7

This poster aiso had your error message

Agent_24
28-06-2011, 11:11 AM
HomeGroup is a PITA anyway -- better to disable it, make sure all computers are on the same workgroup, and use the standard networking.

x2

I've never used it and I've had a lot less trouble than people who I know do use it.

Empathy.
28-06-2011, 12:14 PM
Glad you worked it out :]

johcar
28-06-2011, 11:23 PM
Bugger. I have now joined the naysayers about HomeGroup.

All my fiddling may have enabled HomeGroup sharing but it has broken wireless connectivity on the laptops. #$@*!!!

And now SWMBO is giving me grief!! Mine would give R2x1's dragon a run for her money, I reckon!

I have undone the changes to the Registry and the two services on the laptops, but no luck on the wireless connection (although it seems to be fine when wired).

On SWMBO's laptop I have deleted the "DisabledComponents" key (I had to create it yesterday) and on mine I have set the value back to "ff" (which is what it was yesterday)

Any ideas people?

(I knew there was a reason I didn't like the esoteric magic that comprises networking!)

Speedy Gonzales
28-06-2011, 11:27 PM
Well, I dont know why so many people, have probs with networking. Whether its wired or wireless. Both are pretty straightforward

johcar
28-06-2011, 11:32 PM
Easy to say when you know how... :)

johcar
29-06-2011, 10:21 AM
Not in front of the machines right now, but a brief look before I left home this morning seems to indicate that the HomeGroup connection between my laptop and the PC is still there, and working! Perhaps I need to get the PC to "leave" my HomeGroup, then reconfigure SWMBO's laptop and also leave the HomeGroup on that machine too.

Can't understand why an internal network configuration issue has stopped the wireless connectivity though.

Agent_24
29-06-2011, 10:59 AM
No HomeGroup here and everything works fine for me, in an environment with anything from Windows 3.11 to Windows 7 and any variant of Linux...

Chilling_Silence
29-06-2011, 11:07 AM
Yeah the easiest solution:
Create the identical user accounts on both PCs.
...that's all there is to it.

Same Username, same Password, sorted!

wainuitech
29-06-2011, 12:40 PM
Yeah the easiest solution:
Create the identical user accounts on both PCs.
...that's all there is to it.

Same Username, same Password, sorted! Thats all good and well, BUT the computers them selves cant have the same name -- you cant have two computers on the LAN with the same name, they will clash.

Another big disadvantage with homegroup, it only works on W7, so as Agent points out, with normal networking all OS's can talk.

One other thing I have found as well ( from customers experiences) , most of the time if a person has a Laptop, and is mobile and using homegroup, they have to disable it, remove the laptop from the homegroup if in another location - things simply dont work.

Agent_24
29-06-2011, 01:31 PM
One other thing I have found as well ( from customers experiences) , most of the time if a person has a Laptop, and is mobile and using homegroup, they have to disable it, remove the laptop from the homegroup if in another location - things simply dont work.

The reverse is also true, my friend thought he was clever using homegroup until he hosted a LAN party...

Chilling_Silence
29-06-2011, 02:25 PM
Yeah but your PCs can't have the same name, regardless of if they're part of a homegroup right? So it's not really a big issue there. Just the user accounts.

Hypothetical situation:
Lets say you have two people in home - Jim & Sally
Jim is a gamer and has his Desktop, along with a printer hooked up.
Sally likes to sit in the living room on her laptop, but has a massive internal HDD that she keeps all the photos on.

Jim logs in to his Desktop with the username "Jim" and the password of "j1mmyb0y", so creates an identical account on Sallys laptop.
Sally didn't previously have a password, so she has to make one on her laptop, and then creates the same Sally account on Jims PC, and gives it the same new password as her laptop.

Both can now share printers / files / whatever, without being prompted for a password, as it will pass their currently logged in Username & Password by default (I believe - Correct me if I'm wrong on that).

Phil B
29-06-2011, 03:05 PM
Mine used to give me reliability grief until I enabled Netbios over TCP/IP & all my troubles went away

wainuitech
29-06-2011, 06:49 PM
Both can now share printers / files / whatever, without being prompted for a password, as it will pass their currently logged in Username & Password by default That should work, BUT if all users, were using normal old style networking, and the option in advanced sharing "Turn off password protected sharing" is selected, they wont be prompted for a password anyway.

Sometimes with homegroup where problems can occur is when the person doesn't have a password at all (straight into windows) W7 & vista use the sharing functions of server 2003 - hence they need to have a password entered to log into the Computer (Generally)

Up side to old style networking is any OS can be shared, and have access to the shares, with homegroup you have to have W7 only.

I find it easier to disable it, and avoid a unstable sharing situation.

johcar
29-06-2011, 08:18 PM
Ha! Sorted my wireless connectivity issue. It WAS unrelated (I think) - I restarted the modem and everything is back to normal (and I have my slightly-dented guru crown back on - from my family's perspective, at least!!)

wainuitech
29-06-2011, 10:05 PM
I have my slightly-dented guru crown back on - from my family's perspective, at leastWere the dents caused / related by the comment in post #17 ? :D

And now SWMBO is giving me grief!! :p
Better learn to duck quicker :lol:

johcar
29-06-2011, 11:45 PM
Indeed!

:pf1mobmini: