PDA

View Full Version : Non Wireless Printer



Poppa John
04-03-2011, 11:57 AM
Hi All.
I Think I know the answer to this question already, but here goes.

Comp Pc XP Home SP3. Printer Epson TX300F. Both non wireliess. Printer to comp via USB lead.

Toshiba L10 laptop IS wireless & GWiless router is operating on this network.

Can I Somehow make the printer work from the laptop, other than by it's own USB connection? TIA. PJ

wratterus
04-03-2011, 12:07 PM
If both PCs are on the same network then you can share the printer through the compaq, and when set up as long as the printer and the compaq are turned on the tosh will be able to print.

Poppa John
04-03-2011, 12:13 PM
The PC is a Metlabuild.

Let me see if I have got this straight.

On the Toshiba, I install Printer TX300F, & "Share"it ?

Turn on the PC & Printer, select the printer on the laptop, & thats it? PJ

Agent_24
04-03-2011, 12:57 PM
Almost, you will also need to install the printer drivers on the laptop too.

gary67
04-03-2011, 12:58 PM
Share the printer on the desktop as that is what the printer is connected to. Then go to the laptop and install printer, when it looks for the printer point it at the shared printer, you will need to install printer drivers on the laptop as well as the desktop

MushHead
04-03-2011, 01:01 PM
^^^^ what he said.

If both comps are running XP the laptop should get the driver from the desktop automatically.

Poppa John
04-03-2011, 01:48 PM
Ok...That all sounds a bit heavy for me but I will give it a go. Thanks. PJ

Agent_24
04-03-2011, 02:21 PM
It's really very simple.

Here's a step-by-step : http://www.microsoft.com/windowsxp/using/networking/expert/honeycutt_july2.mspx

SolMiester
04-03-2011, 03:17 PM
An easy method I use once the printer is shared, is to do a search for the computer that has the printer, double click on it then right the printer show and click connect. This will pull the drivers over for you!

Poppa John
04-03-2011, 07:12 PM
OK...It hasn't worked so I must have got it wrong.
What I have done is :- Connected the laptop to the printer with the USB & let it Plug & Play. Put in the CD & installed the printer. Gave it a name. Went into the printer & enabled sharing & made the printer name the same. Printed a test page & Ok.

Reconnected the printer USB to the computer. Brought up the laptop printer & asked for a testpage. Nowt.

So where have I gone wrong? PJ

Agent_24
04-03-2011, 07:18 PM
I think you went wrong connecting the printer to the laptop directly, because when you installed the driver it has been installed as if the printer was local.

When you moved the printer back, the settings are wrong.


You need to share the printer on the desktop via the printers and faxes in control panel

Then on the laptop, go through the standard windows "Add printer" wizard but choose to add a network printer rather than a local one. Browse for the printer and select it.

If you get asked for drivers, select the correct printer as appropriate and give it any disks it asks for.

Poppa John
04-03-2011, 07:27 PM
Deleted printer.
Cannot connect to the network, have not got as far as "Drivers or Disc". PJ

Agent_24
04-03-2011, 07:29 PM
What can't connect to the network? Can you upload a screenshot of any specific error etc?

Poppa John
04-03-2011, 07:34 PM
What can't connect to the network? Can you upload a screenshot of any specific error etc?

"Windows cannot connectto the printer. Eitherthe printer name was typed incorrectly orthe specified printer has lost its connection to the server"

What server. remember that this is NOT a wireless printer but hard connected to a PC. PJ

Speedy Gonzales
04-03-2011, 07:37 PM
Make sure file sharing is enabled on both computers as well

Poppa John
04-03-2011, 07:40 PM
Make sure file sharing is enabled on both computers as well

Is this on the printer, PC & laptop? I have clicked Sharing on pinter it self & on each Computer Printer setup. PJ

At the moment there is NO printer on the laptop PJ

Speedy Gonzales
04-03-2011, 07:43 PM
All 3. What computer printer setup?? You only have to do it once (tick the option under the sharing tab on the printer in control panel)

Poppa John
04-03-2011, 08:01 PM
All 3. What computer printer setup?? You only have to do it once (tick the option under the sharing tab on the printer in control panel)

On the computer printer page, Sharing is ticked. The printer is "EPSONTX300FSERIES" that is what I am using throughout.

I suspect that the wireless laptpo is not talking to the computer via the wireless router thingy. As I said before there is NO printer installed on the laptop. PJ

Poppa John
04-03-2011, 08:05 PM
Just had a look at My Compter on the PC, at Properties. I see that there is a section on File Sharing, nothing of which is ticked!!! PJ

Agent_24
04-03-2011, 08:08 PM
Just had a look at My Compter on the PC, at Properties. I see that there is a section on File Sharing, nothing of which is ticked!!! PJ

Where is that? I can't find it on mine.. but maybe you need to enable it.

Poppa John
04-03-2011, 08:12 PM
Where is that? I can't find it on mine.. but maybe you need to enable it.

My Computer.

Local disc C

Properties. PJ

Speedy Gonzales
04-03-2011, 08:25 PM
Dont share ALL of C. If you want to share a folder, create a folder then share it

Poppa John
04-03-2011, 08:32 PM
Dont share ALL of C. If you want to share a folder, create a folder then share it

OK.

How can I tell if the laptop is connecting to the Belgin wireless unit & then thro to the PC/printer?

I know the printer works from the laptop on a usb cable connecting them both. PJ

Agent_24
04-03-2011, 08:33 PM
That won't change if file sharing is enabled, it will just share your entire C drive on the network.

Try running the network setup wizard and making sure you enabled printer sharing. Note that this will automatically enable Windows firewall, so if you don't use it, make sure you turn it off again afterwards.

Agent_24
04-03-2011, 08:40 PM
If you do use Windows firewall, check in the settings that the exception for File and Printer sharing is enabled.

Speedy Gonzales
04-03-2011, 08:41 PM
Dont use the network wizard in XP. Its hopeless and never worked

Poppa John
04-03-2011, 08:42 PM
That won't change if file sharing is enabled, it will just share your entire C drive on the network.

Try running the network setup wizard and making sure you enabled printer sharing. Note that this will automatically enable Windows firewall, so if you don't use it, make sure you turn it off again afterwards.


I don't want to disturb the Network. There is a printer & laptop working well on wireless at the moment. My Wife's!!!!! PJ

Poppa John
04-03-2011, 08:46 PM
Shutting down now, will try again tomorrow. PJ

berryb
04-03-2011, 09:27 PM
Both computers should be in the same workgroup.
Both should have internet access. (this is just to make sure they are connected to the network)
Share only on the desktop via printers and faxes.
On laptop add network printer and choose middle option and you should see your shared printer on the desktop.

Steps are close but not step by step.

Poppa John
05-03-2011, 10:21 AM
Ok People. I am sorry but I give up. I just cannot do it.

Our Network is ok. We have a laptop & its printer, both wireless, working. I am not going to risk disturbing this & causing Maryann distress.

SOOO... I will load the printer onto the L10 laptop & use a USB lead when I need to print.


Thankyou for your help & suggestions. PJ :thanks:waughh:

Agent_24
05-03-2011, 11:49 AM
Dont use the network wizard in XP. Its hopeless and never worked

What? It's always worked perfectly for me...

Speedy Gonzales
05-03-2011, 11:51 AM
One out of a few billion then, its easier if you do it manually / yourself

Agent_24
05-03-2011, 11:51 AM
Ok People. I am sorry but I give up. I just cannot do it.

Our Network is ok. We have a laptop & its printer, both wireless, working. I am not going to risk disturbing this & causing Maryann distress.

SOOO... I will load the printer onto the L10 laptop & use a USB lead when I need to print.


Thankyou for your help & suggestions. PJ :thanks:waughh:

One of us could try and help you via Teamviewer...

SolMiester
05-03-2011, 11:53 AM
Did you do as i suggested and try to find the desktop PC which has printer attached via the search function of windows?....
Search>computers>computername, double click resultant PC, right click the printer and connect!

Agent_24
05-03-2011, 11:53 AM
One out of a few billion then, its easier if you do it manually / yourself

I guess you would have better control and it would stop it turning windows firewall on by itself, although that is no big deal...

SolMiester
05-03-2011, 11:54 AM
One of us could try and help you via Teamviewer...

Yeah, have to agree easilier to just do it for them than try explain in words!

Speedy Gonzales
05-03-2011, 11:57 AM
True and it'll take less than 30 secs - a min to fix it

Agent_24
05-03-2011, 11:57 AM
Go to the properties of your LAN or WiFi connection on the desktop and make sure the file and printer sharing is enabled

(you can get there through control panel -> network connections)

Poppa John
05-03-2011, 01:13 PM
Go to the properties of your LAN or WiFi connection on the desktop and make sure the file and printer sharing is enabled

(you can get there through control panel -> network connections)


It IS selectred.

Going to give it all some thought & I will come back later. Thanks. PJ

Poppa John
05-03-2011, 05:31 PM
Ok...I have thought. I am not going to mess about with the network & th wireless setup as it is. I hve installed a printer on this L10 laptop to work off an US lead. I ave tried it & it works.

It will not be often that I need to print from here. Also I can always put it on a Nano drive & move it to the PC.

So,Again thanks for all the help, the feeble brain is mine alone. PJ

Nomad
05-03-2011, 06:46 PM
^^^^ what he said.

If both comps are running XP the laptop should get the driver from the desktop automatically.

Even if they are diff OS.
On the main computer with the local printer *I think* you can go to a menu tab and you can tick the different operating systems. So if the laptop upstairs that runs WinXP wants to print, it can and it might not need to install drivers.