PDA

View Full Version : plugged in, not charging



gum digger
01-02-2011, 11:41 PM
Hi
Friends laptop (CQ50) compaq, showing that i have plugged in but its not charging. this randomly happened. he is running vista home. After talking to my friend google, it suggested i uninstall "ACPI-Compliant Control Method Batter" and scan for changes in order to reinstall it. but this does not work. i have updated bios also but no luck.

technically if this was a software issue it should charge when laptop is turned off and not charge if its in windows. but the power indicator (also charging indicator) does not lit up.

Any other suggestions?

kahawai chaser
02-02-2011, 12:02 AM
Battery? Could try a utility like battery care (http://download.cnet.com/BatteryCare/3000-20430_4-10964408.html?tag=mncol;2) to monitor it's performance and charge/discharge cycles.

feersumendjinn
02-02-2011, 12:13 AM
Is it going when plugged into the mains, but not on battery alone? There is a switch built into the laptop's power socket, which controls whether it's powered from either source, perhaps it's broken.
Or perhaps the battery is shot.

gum digger
02-02-2011, 09:47 AM
Is it going when plugged into the mains, but not on battery alone? There is a switch built into the laptop's power socket, which controls whether it's powered from either source, perhaps it's broken.
Or perhaps the battery is shot.

it only works if mains plugged in, whether battery is inserted or not.

you reckon if i disconnect that switch from the board i might be able to diagnose it further?

Nomad
02-02-2011, 09:49 AM
it only works if mains plugged in, whether battery is inserted or not.

you reckon if i disconnect that switch from the board i might be able to diagnose it further?

maybe the battery is flat not holding a charge.
so it requires the power cable with or without the battery.
and maybe the battery needs replacement ...

happens on my used laptop too but they guy said the tech said needs a new batt which i have not yet bought.

gum digger
02-02-2011, 10:12 AM
maybe the battery is flat not holding a charge.
so it requires the power cable with or without the battery.
and maybe the battery needs replacement ...

happens on my used laptop too but they guy said the tech said needs a new batt which i have not yet bought.

Yeh as this happened suddenly

Speedy Gonzales
02-02-2011, 10:32 AM
Looks like its a known issue with this model. According to google. Heaps of people have the same prob. Some people have even replaced the battery, it made no diff at all