PDA

View Full Version : Laptop won't turn on



--Wolf--
25-01-2011, 09:57 AM
Last night pulled the TV audio cable out of laptop and as soon as I put my Logitech speaker cable in (in the right slot and have done it hundreds of times) the laptop just shut off. No sound no nothing.

Left it overnight and it still won't turn on, with or without power. No lights showing anywhere. It's a Asus K50IJ that was running Win7.

I think it should still be under warranty but can't find the receipt so can't double check, but I need it fixed asap and tbh I have no idea what's wrong with it. I hope it's not fried, do laptops have fuses/circuit breakers?

And what should I do with it? Could I take it down to the tech repairs guys at HN and will them opening it void the warranty? No idea what to do...

SolMiester
25-01-2011, 10:57 AM
Audio is just an output, im not even sure if it have any voltage, if it does, it would only be 5v, hardly enough to fry the board.....I too remove and insert audio cables all the time....just as i do with video feed....??

pctek
25-01-2011, 11:09 AM
It's a Asus

I think it should still be under warranty

Take it here:
http://www.techcentral.co.nz/
Ground Floor, 60 Hugo Johnston Drive, Penrose, Auckland. Phone, 09-571 2418. Fax, 09-571 2410. E-Mail, enquiry@techcentral.co.nz

They are the repair agenst fo ASUS, warranty and non-warranty.

You can courier it too.

--Wolf--
25-01-2011, 11:17 AM
Better yet.

Just rung them, told me to take the battery out, plug it in and turn it on. And it works.

Then plugged the battery in when it was going, unplugged it and it still works. Amazing.

No idea what that means but it seems to work fine now so I'm happy.

PeeCeeWorldly
25-01-2011, 11:18 AM
Unplug power, remove battery, leave untouched for awhile. Try to power up after a few hours. Might help..

Some info here: http://www.insidemylaptop.com/disassemble-asus-k-series-notebook/

linw
25-01-2011, 02:43 PM
You just pressed the master reset button!!

The Error Guy
26-01-2011, 12:06 AM
this could be a static problem (freaked me with my lappy too!!!) take out power and and battery, press and hold power button for 10secs. re insert power and try to boot. if that fails try doing the power button thing with the power plugged in or with the battery in.

dunno how it worked but my laptop was the same then suddenly it booted :p