PDA

View Full Version : All folders 'Read Only' and greyed out?



Billy T
13-12-2010, 08:50 AM
Pursuing my issues with the 'Read Only' SD card I have found that all folders on my computer (or at least my data drive) have been set to 'Read Only' and being greyed out, I can't change them. I discovered this when I tried to rename one folder and it declined my offer. I was renaming folders as recently as a week ago without problems.

Since this appears to have been a global change, I'm picking (and hoping) that there may be a similarly global means to reverse this. I used to do this sort of thing globally in DOS, and XTree / ZTree but I'm wary of making a king-size muckup!

I've had a good look, but since I don't venture under the bonnet too often I've not found anything hlepdful yet. I expected to find in at the root of the disk (or partition in many cases here) but either I'm blind, or stupid, or perhaps Mrs T is right and I need a minder and a leash.

So far as I can see with a spot check, all files remain read/write.

Cheers

Billy 8-{) :confused: :help:

1101
13-12-2010, 09:12 AM
Robocopy has a reset/change attrib switch

/A-:RASHNT
pretty sure you can use robocopy to change attribs on existing files
You may need to google it further

Billy T
13-12-2010, 11:44 AM
Robocopy has a reset/change attrib switch

/A-:RASHNT
pretty sure you can use robocopy to change attribs on existing files
You may need to google it further

Thanks, but I'll hold on that for a while though. I've found an answer on Google that is specific to this issue and it requires entry of this: attrib -r +s d:\[folder name] at the command prompt, but my prompt doesn't come with the root as C:\, instead I get C:\Documents and Settings\User Name>

I am reasonably comfortable at the command prompt, having used it extensively over the years, but I'm rather reluctant to enter a command prefixed by all of that gumbo. However, I have been unable to change that to the C:\ prompt on its own. It insists on retaining that path.

Is that actually acting as a default root, or what am I doing wrong here?

Cheers

Billy 8-{) :confused:

Snorkbox
13-12-2010, 11:48 AM
Use the command CD\ to step back to the root of C:

When you get there try attrib /? for various commands.

Billy T
13-12-2010, 01:10 PM
Use the command CD\ to step back to the root of C:
When you get there try attrib /? for various commands.

Mrs T might be right! Maybe I am losing my grip.

I had tried the 'change directory' command but must have used CD/ instead! :blush:

Cheers

Billy 8-{)

Well, I got it right and it executed but the folder is still read only!

feersumendjinn
13-12-2010, 11:04 PM
Maybe this will help
http://www.computerhope.com/msdos.htm

mikebartnz
14-12-2010, 09:15 AM
What OS. If Win7 you may need to change permissions before you can change read only.
If so Right click on your data directory and go to security.

Billy T
21-12-2010, 03:18 PM
Well I never!!!!!

The SD card returned to normal of its own accord and now reads, writes & deletes etc (I took it away on a brief holiday so it must have just needed a change of scenery and less swearing.) :D

However, I still can't rename folders on my computer. Maybe I should send it on holiday with Speedy, then it might behave when it gets back! It is not a major problem anyway, not as annoying as the SD card was, so I'll come back to it in a few weeks.

Cheers

Billy 8-{) :)