PDA

View Full Version : W7 pro 64 bit - got 4 GB ram but 2.94 usable!



Fishb8
07-12-2010, 10:20 AM
Why is that - thought 64 bit applications used all 4 GB?
What's the other 1 GB doing?

Speedy Gonzales
07-12-2010, 10:24 AM
Whats the videocard?? Onboard? PCI-E? How much ram is on it?

inphinity
07-12-2010, 10:30 AM
Where does it display 2.94GB? If you right click Computer and go to Properties, can you show us what it displays there - for OS, Processor, and memory?

Fishb8
07-12-2010, 11:52 AM
Installed memory - 4GB, (2.94 usable)
Belarc
3008 Megabytes Usable Installed Memory

Slot 'DIMM0' has 2048 MB
Slot 'DIMM1' is Empty
Slot 'DIMM2' has 2048 MB
Slot 'DIMM3' is Empty
NVIDIA GeForce 9500 GT, 1024 Mb

Speedy Gonzales
07-12-2010, 12:04 PM
Thats probably where 1 GB went - that card

pablo d
07-12-2010, 12:17 PM
I'd say it's just a coincidence that your GPU has 1GB of RAM and you're missing 1GB of usable RAM, but it may well be your video card causing it for other reasons.

See if you can find a setting in your BIOS something along the lines of "Shared VGA Memory". If you can't find it/aren't comfortable in the BIOS, post up your model of motherboard and I'll have a quick squizzle for you.

SolMiester
07-12-2010, 12:18 PM
Thats probably where 1 GB went - that card

No, that's not correct, 64bit will show all memory period, i suspect the program is reporting wrong..
OP - go to control panel>system and report o/s and ram shown there.

Snorkbox
07-12-2010, 12:22 PM
Or follow post #3 instructions. Then take a screenshot.

pablo d
07-12-2010, 12:27 PM
Actually does your 9500GT have/use "Turbocache"?

wratterus
07-12-2010, 12:31 PM
Are you 100% sure you are running 64bit?

inphinity
07-12-2010, 12:32 PM
I'm not convinced you are using a 64-bit edition of Win7.

Speedy Gonzales
07-12-2010, 01:01 PM
Is memory remap feature enabled in the BIOS?

Fishb8
07-12-2010, 03:43 PM
1994

1995

1996
Definitely 64 bit
Asus P5B motherboard - not able to adjust the shared memory in BIOS.

inphinity
07-12-2010, 04:09 PM
1994

1995

1996
Definitely 64 bit
Asus P5B motherboard - not able to adjust the shared memory in BIOS.

With a P5B you will need to enable Memory Remapping, in BIOS > Advanced > Chipset > Northbridge Chipset Configuration, as without it the northbridge memory controller will be hitting its maximum address ranges with a 1GB video card.

Fishb8
07-12-2010, 07:00 PM
Cheers - will have a look tomorrow (nights, tonight)!

Fishb8
08-12-2010, 12:44 PM
OK - went into BIOS and changed the memory controller, re-booted and found it was now showing only 2GB!! Still, It was some sort of progress.
Googled and around that I needed to go to msconfig/boot/advanced options/ -uncheck the maximum memory box and reboot.
Now showing as 4GB installed ram!!!
Got it!!

Battleneter2
08-12-2010, 02:27 PM
OK - went into BIOS and changed the memory controller, re-booted and found it was now showing only 2GB!! Still, It was some sort of progress.
Googled and around that I needed to go to msconfig/boot/advanced options/ -uncheck the maximum memory box and reboot.
Now showing as 4GB installed ram!!!
Got it!!

You have a bad Ram Dim, if your board supports it test one at a time, the bad Dim prob wont post by itself and will be unstable at best.

Seen this before.

Snorkbox
08-12-2010, 02:30 PM
You have a bad Ram Dim, if your board supports it test one at a time, the bad Dim prob wont post by itself and will be unstable at best.

Seen this before.

Did you read post #16?

Battleneter2
08-12-2010, 02:38 PM
Did you read post #16?


um um well the first half :P

Snorkbox
08-12-2010, 03:01 PM
:)

Fishb8
08-12-2010, 06:14 PM
All running sweetly!!

Deimos
08-12-2010, 07:41 PM
1994
Definitely 64 bit
Asus P5B motherboard - not able to adjust the shared memory in BIOS.

Unfortunately I had the same problem with my P5B-e, I didn't spend too long troubleshooting (it was a home theater machine so I didn't care too much), and I didn't find a fix.

Interestingly Server 2008 worked flawlessly on the same board with 8GB ram installed.

Edit - Oh, I see you found a fix...