PDA

View Full Version : windows 7 network access issues



williamF
02-12-2010, 05:10 PM
hi, i got a brand spanking laptop with windows 7, it does fricken everything, but it doesnt let me in to my windows 2k based video server or webserver via the UCN paths or the icons for that matter (not sure on XP ones but it wont let me use the shared printer on one of them) to view the shares on it, the video server has no login password you usually just type in the name "william" with no password and it shows the video folder shares but in 7 it keeps asking me for some bloody password neither computer should have (i have tried setting the laptop's one blank as well)
my webserver should be similar except you type in a password, and even then it keeps asking for some odd password which i dont know or as far as i am aware am typing correctly

either way it fails and doesnt let me in to view the shares

is there actually a way of disabling this as i dont know what the heck password its on about and its not letting me into those particular computers:badpc::annoyed:

wainuitech
02-12-2010, 05:40 PM
Click Start, type in Network, look for Network and Sharing - On the top left, click changed advanced sharing settings.

Make sure network discovery is enabled, turn on printer sharing and near the bottom turn off password protected sharing So it looks like this (http://www.imagef1.net.nz/files/Sharing1291264757.jpg) - the highlighted ones.

Pays to make sure your work group on the laptop is the same as the other PC's / Servers. By Default W7 uses the name Workgroup.

williamF
02-12-2010, 05:52 PM
http://img338.imageshack.us/img338/9973/sett.jpg

wainuitech
02-12-2010, 06:18 PM
Check one thing -- Something really strange - on ALL the PC's Servers check their time and date - came across that when running W7 beta, one of my servers was out by 2 days and it wouldn't share with W7, after correcting it - bingo.

From memory W7 doesn't like blank passwords either - you can try actually creating a password on the offending machines and see if that does any good -- or not.

williamF
02-12-2010, 06:23 PM
Check one thing -- Something really strange - on ALL the PC's Servers check their time and date - came across that when running W7 beta, one of my servers was out by 2 days and it wouldn't share with W7, after correcting it - bingo.

From memory W7 doesn't like blank passwords either - you can try actually creating a password on the offending machines and see if that does any good -- or not.

both computer's times are correct within one or two minutes, the video server password is blank for a reason so i prefer it to stay blank but i will try with a password

wainuitech
02-12-2010, 06:42 PM
Just found the following: Its based on XP professional, BUT since Xp was built from Win 2000 anyway, it may just work.

Cant test it, as I dont have any Win2000 machines about -- the OS is simply to old, and I have newer ones.

Permitting Network Access Without a Password

To allow users to log onto their computers without a password and then access the XP Professional machine without a password, you must make a security policy change:

1. Go to Control Panel | Performance and Maintenance | Administrative Tools | Local Security Policy.
2. Expand Local Policies | Security Options.
3. Double-click Accounts: Limit local account use of blank passwords to console login only, which is enabled by default. Disable this option and click OK.

this stopped the network access dialog box appearing when tryin to access my xp machine from windows 7 ! !

williamF
02-12-2010, 07:09 PM
am i doing this on the remote machines or the win7 machine either way i cant find those specific settings in 2k and win7 makes those settings jolly hard to find

wainuitech
02-12-2010, 07:43 PM
Depending on what version of W7 you have the options may not be available.

What are you running ?

I'm using Ultimate on all mine and the options are there. Just looked on a new Customers W7 Home Pre, and the option is not there.

AS for the Options in W2K, as I mentioned, the article was for XP Pro -- so may not be there in W2K, it was only a guess since XP was built from W2K, and I dont have any PC's running that old a systems.

williamF
02-12-2010, 07:44 PM
ok, it is home premium

Speedy Gonzales
02-12-2010, 07:46 PM
I'll check it out in 2k, from an ISO I slipstreamed in VirtualPC. And see whats there

Speedy Gonzales
02-12-2010, 08:27 PM
If you go to control panel / user and passwords, and untick users must enter a username an pw to use this computer. You wont need either when you boot into 2K. I cant see anything about Permitting Network Access Without a Password tho

wainuitech
02-12-2010, 09:10 PM
The setting I mentioned Previously are available on XP Pro - this is Screen Shoot of the setting (http://www.imagef1.net.nz/files/Accounts_XP_Pro.jpg) is from XP mode in W7 ( since its XP Pro) as well as the security settings in W7 Ultimate As shown (http://www.imagef1.net.nz/files/User_Accounts.png) -- BUT since W7 home has limited features for home users,not like Professional and above, the setting is not there.

Some other way around the password has to be found.

I have had similar prompts with W7 Home ( when mucking about with it), and the only way around it was to have the user name passworded on the PC you are trying to access, which was XP Home, when you entered the user name and its password for the machine it allowed access - I'm reasonably sure W7 wont accept blank passwords with user names on sharing unless security settings are changed.

My suggestion - its either password it, or change the way you would log into it (straight in) - no user name needed. (as speedy suggested)

I suspect W2k is throwing up the same sort of blocks, needing a password.

wainuitech
02-12-2010, 09:41 PM
Just dumped W2k Onto a drive -- cant test this as it has no drivers, network, audio etc.


On the W2K machine, go to the shared folder, right click it, click sharing, Security Tab - Add -- Select from the list "everyone", click add - apply.

Down the bottom left, click on the advanced button - double click "everyone" from the list, tick the boxes under allow that you want - if you want full access tick them all. apply/Ok reboot, now see if you can log in via W7.

If that doesn't work instead of adding "everyone", create a new user on W2k , Example "William" and give it a password. Then under sharing options mentioned above, add the new user, change the access as required.

When trying to access the shares, for the user name, use the same one you created on W2K and its password.

If this works, you will have to do that ( add the user) to every shared folder ( main folder only, its subs, if they have any should allow access)

Just a question: From the original post
windows 2k based video server Is this a normal W2k OS or the proper W2k Server -- there is a differance.

ronyville
02-12-2010, 09:47 PM
my webserver should be similar except you type in a password, and even then it keeps asking for some odd password which i dont know or as far as i am aware am typing correctly


normally with Win7 you need to provide the domain name and username. for e.g, if the PC is named PC1, and connecting from Win7, when prompted for a username and password, type it in as PC1\username. This may work also for the video server. If you dont have a username and password for the video server than you will have to create one. Hope this helps.

williamF
03-12-2010, 11:09 AM
Just a question: From the original post Is this a normal W2k OS or the proper W2k Server -- there is a differance.

its just a normal 2k machine with a couple of 500 gig hard disks full of captured movies nothing too flash

williamF
03-12-2010, 11:31 AM
ok i have tried a few things:
changing the user name on the webserver didnt help
"computername\username" changed the domain but it didnt work either

this time it pauses like its doing something but it still gives me the damn same box with a different user icon thingy
tried on the webserver it has a password and the TVPC without

ronyville
03-12-2010, 11:33 AM
ok i have tried a few things:
changing the user name on the webserver didnt help
"computername\username" changed the domain but it didnt work either


just to be sure, the username is the user on the 2k PC and not on the W7 PC right? and both the PCs are on the same workgroup?

williamF
03-12-2010, 11:37 AM
just to be sure, the username is the user on the 2k PC and not on the W7 PC right? and both the PCs are on the same workgroup?

yes the user name on the 2k machines and yes they're on the same workgroup

SolMiester
03-12-2010, 11:47 AM
Not the best solution but can you convert the disk to Fat32 or do you have file size issues....

williamF
03-12-2010, 12:03 PM
Not the best solution but can you convert the disk to Fat32 or do you have file size issues....

most of the videos are under 4 gig but on the odd occasion i will have files that exceed 4 gig DVD ISO images, long capture files and the like and the space to put the files while formatting is limited, i have a nearly full 500 gig and a half fill second one

ronyville
03-12-2010, 01:38 PM
did some research and it could be the NTLM issue. Win 7 uses NTLM 2 by default i am guessing. try this out

go to local policies and change the LAN manager authentication level to "send LM & NTLM - use NTLMv2 session security if negotiated. Probably restart your Win 7 pc and trying connect again using the PC1\username method. Here's a PIC (http://www.imagef1.net.nz/files/NTLM.png)

williamF
03-12-2010, 02:21 PM
did some research and it could be the NTLM issue. Win 7 uses NTLM 2 by default i am guessing. try this out

go to local policies and change the LAN manager authentication level to "send LM & NTLM - use NTLMv2 session security if negotiated. Probably restart your Win 7 pc and trying connect again using the PC1\username method. Here's a PIC (http://www.imagef1.net.nz/files/NTLM.png)

i did find it by chance at one stage but i dont know where i went i think it was on the 7 computer anyway where do you go to get that window :blush:

Speedy Gonzales
03-12-2010, 02:23 PM
Or the registry (http://support.microsoft.com/kb/239869)

SolMiester
03-12-2010, 02:51 PM
did some research and it could be the NTLM issue. Win 7 uses NTLM 2 by default i am guessing. try this out

go to local policies and change the LAN manager authentication level to "send LM & NTLM - use NTLMv2 session security if negotiated. Probably restart your Win 7 pc and trying connect again using the PC1\username method. Here's a PIC (http://www.imagef1.net.nz/files/NTLM.png)

Ah, you are on to something there...try this on the W7 PC, we had to for our proxy authentication....

1. In HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Lsa
If it doesn’t exist, create a DWORD value named LmCompatibilityLevel and set the value to 1 to use LM NTLM and NTLMv2 if is negotiated, this is Also it works establishing the value to 0, and 3 though for more safety the value using 3 though with old operating systems it will not work on having used obligatorily NTLMv2.

2. Reboot

wainuitech
03-12-2010, 03:26 PM
did some research and it could be the NTLM issue. Win 7 uses NTLM 2 by default i am guessing. try this out

go to local policies and change the LAN manager authentication level to "send LM & NTLM - use NTLMv2 session security if negotiated. Probably restart your Win 7 pc and trying connect again using the PC1\username method. Here's a PIC (http://www.imagef1.net.nz/files/NTLM.png) The changes would have to be done Via the registry, since W7 Home Pre ( which this is) doesn't have the the local polices/security options, like pro and above does.

SolMiester
03-12-2010, 03:50 PM
I have posted the reg key!

dugimodo
03-12-2010, 03:53 PM
a possible workaround (although not one I'd like to use) is to use media players sharing options which seem to work a little differently. Assuming the win 2k machine has a compatible version of media player of course turn on media sharing and add some things to the library, they should then be accessible from the network.

Networking is not my strong point though so apologies if this is a stupid suggestion.

Speedy Gonzales
03-12-2010, 04:01 PM
You may have to do this (http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/033c418b-1096-4df7-bfad-fd3d431f3cd5)

ronyville
03-12-2010, 04:06 PM
i did find it by chance at one stage but i dont know where i went i think it was on the 7 computer anyway where do you go to get that window :blush:

start > type in "edit group policy" BUT like Wainui said, you have Win 7 Home so may not have this option.. so will gona have to edit the registry settings.

williamF
03-12-2010, 05:15 PM
Ah, you are on to something there...try this on the W7 PC, we had to for our proxy authentication....

1. In HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Lsa
If it doesn’t exist, create a DWORD value named LmCompatibilityLevel and set the value to 1 to use LM NTLM and NTLMv2 if is negotiated, this is Also it works establishing the value to 0, and 3 though for more safety the value using 3 though with old operating systems it will not work on having used obligatorily NTLMv2.

2. Reboot

1: http://img811.imageshack.us/img811/5013/regedit.jpg done
2: pending

williamF
03-12-2010, 05:24 PM
after reboot everything is working fine after adding the registry entry. my sister has a similar laptop which i may have to do the same mod to get it going but its getting repaired as the internal speakers werent working when she got it