PDA

View Full Version : Keyboard inserting " instead of @



Beemer
19-11-2010, 08:33 AM
I've struck this problem before but can't find the answer online anywhere! I am working somewhere at present and my keyboard is inserting " instead of @ when I use the shift key.

I know there is a simple fix but I can't for the life of me find it. I've tried looking in keyboard and regional and language options but no matter what I do, it's still doing it.

It's a standard PC keyboard.

Zippity
19-11-2010, 08:38 AM
Does this happen using all fonts or just one in particular?

pcuser42
19-11-2010, 08:42 AM
I had this issue once before. The owner of the PC used the wrong keyboard layout. Check to make sure that you're using the US keyboard layout, not UK.

Beemer
19-11-2010, 08:52 AM
How do I check that? I know I struck the same problem when I bought a laptop and it was an easy fix but I can't remember what I needed to do to fix it!

It's happening in Calibri which is the font we use at work, but it still did it when I switched to Arial.

Zippity
19-11-2010, 08:54 AM
Have you checked your Country/Region settings?

pcuser42
19-11-2010, 08:57 AM
How do I check that? I know I struck the same problem when I bought a laptop and it was an easy fix but I can't remember what I needed to do to fix it!

It's happening in Calibri which is the font we use at work, but it still did it when I switched to Arial.

It depends on the OS, but here on Vista, in Control Panel, I click Clock, Language and Region > Regional and Language Options > Keyboards and Languages tab > Change keyboards. The process should be similar in Windows 7. Off the top of my head, it's Regional and Language Settings in Windows XP.

Beemer
19-11-2010, 09:04 AM
Right, we are using XP and I have looked in Regional and Language Settings but can't figure out what to do. The keyboard is set to UK language but it says it's in use so can't change it - if I shut down all my programs will it allow me to do it then - and will it fix the problem?

Thanks everyone - just went in and removed the UK and NZ and Maori English version on the keyboard and just left US - @ symbol working as it should now! I knew it was simple but it was the removing the others that I had forgotten!

pcuser42
19-11-2010, 10:09 AM
The keyboard is set to UK language but it says it's in use so can't change it

That's perfectly normal - a reboot is all that's needed after that. :)

Beemer
19-11-2010, 09:33 PM
Well blow me down if I didn't get home and find my bloody laptop did the same thing tonight! Different PC, different operating system, but same problem! It makes me wonder if it was some key combination I hit by mistake on both machines - not sure if my desktop is doing the same as I don't think I used any double quote or @ symbols when typing earlier. I wouldn't be surprised if I scored the trifecta though!