PDA

View Full Version : Computer not turning on



jackchet
15-11-2010, 04:46 PM
My computer was running fine in the morning. I set it to sleep while I went out to run some errands. I came back less than an hour later and it doesn't turn on anymore.

Any suggestions on whats wrong? I don't know if its related but I often got BSOD errors while the computer was set to sleep.

Specs are
Core 2 Duo E6600
Gigabyte P35 DS3R v1.0
2 x 2gb Corsair, although they are different models
2 x 1gb G.Skill
Enermax Liberty 620W

Computer is about 3-4 years old. I'm assuming the Power supply died for some reason, is there any way to check?

Speedy Gonzales
15-11-2010, 04:49 PM
What version of windows is on it, and what was the stop error for the BSOD?

jackchet
15-11-2010, 04:58 PM
It was running Windows 7. stop error? Is that referring to the information that pops up on the bsod? If so i'm not sure. I only knew it was bsoding because when I tried to wake the computer from sleep, it wouldn't respond, and i would have to press the power button to start it up again. Upon windows starting up again i would get the message box saying windows has recovered from an unexpected crash, and it would display BSOD as the reason, but i didn't look further into it as it would never bsod on me while i was on it.

Well actually it had bsod'ed frequently before while i was on it, but that was due to faulty memory module, which replacing fixed.

Speedy Gonzales
15-11-2010, 05:05 PM
Yup a BSOD usually brings up a stop error with something like xxxx and it may also show the name of a file or driver.

Does the on/off button feel stiff? I would check and see if its making contact. I would say its either the power supply. Or the on/switch may not be making contact. I would open the case, and see if anything has blown like capacitors. If it doesnt turn on at all

Paul.Cov
15-11-2010, 05:36 PM
Pull the plug out at the wall socket. Leave it all unplugged for about 10 mins, then try again. Sounds silly, but I've seen this work.

wainuitech
15-11-2010, 05:48 PM
Pull the plug out at the wall socket. Leave it all unplugged for about 10 mins, then try again. Sounds silly, but I've seen this work. Its not silly -- had the same thing happen as well for several customers.

Speedy Gonzales
15-11-2010, 05:49 PM
Or maybe the CMOS battery is flat?

jareemon
15-11-2010, 06:05 PM
Make sure it is switched on at the wall :)

Seeing you have 4 ram modules, and you have had problems with ram before, try removing 3 of them. Failing that, remove it and try another one.

jackchet
15-11-2010, 06:26 PM
I borrowed a PSU from one of the other computers and my computer turned on fine. I would have thought a $250 PSU would have lasted longer than 3 1/2 years :/

Any recommendations on a replacement PSU?
I was thinking of this 550w Cooler master one.
http://pbtech.co.nz/index.php?item=PSUCLM0550
My GPU is a 4850, and i've only got 2 harddrives. 550W should be enough right?

Also might it be possible to salvage the enermax somehow?

jareemon
15-11-2010, 06:34 PM
Should be fine

jackchet
15-11-2010, 06:41 PM
The annoying thing is, that the warranty is period is 3 years, and according to receipts of other parts purchased its been about 3 years 4 months since I've purchased it.

feersumendjinn
15-11-2010, 06:48 PM
It may be repairable, chances are good that it has just popped some capacitors.