PDA

View Full Version : VistaQuest FS-501 Scanner for slides, etc



straka01
09-06-2010, 02:06 PM
I've just bought a VistaQuest FS-501 Scanner.
I don't have an SD card for it.

I've plugged it into my XP PC (using the USB cable supplied) after installing the driver.
Now the LED light comes on when I open the cover but when I insert some film into the scanner no image is displayed on the screen.

The screen does work when it's first turned on (shows the bootup image) but then goes off and it doesn't matter which buttons I press it won't display the images???

Does it have to have an SD card in it to make it work?

Sweep
09-06-2010, 02:14 PM
It has 32 Mb internal memory so it should not need an SD card.

straka01
09-06-2010, 03:09 PM
When I insert the slide with the slides in... should the photos display in the screen straight away (as long as its got power on)?
I've tried pressing the buttons, but no life - just the LED glowing.

pointdexter
09-08-2010, 10:46 PM
hello - this is my first post on this forum - just joined!

I've just got a VistaQuest FS-501 film scanner and had the exact same problem as straka01:

no image on LCD screen and no sign of life other than the red LED light on the top of the box when lids open. Hmph.

you are right that you are meant to be able to see photos in the display screen...
the way that I've gotten around it is to play around with the USB cable at the back socket of the scanning box...seems that if you insert the cable about half way in then the screen will light up and stay lit up.
There's a certain point where the cable can be partially in the socket and will work.

I'm guessing this is a manufacturing fault.

now I've just gotta work out how to import images of my negatives from the scanner to the actual computer.

good luck!