PDA

View Full Version : Kubuntu, static IP addresses and Telstraclear - help needed



decibel
30-05-2010, 03:28 PM
I have provided an old computer running Kubuntu 8.04 for a friend and she has gone from dial-up to Telstra broadband.
At my house, her computer works fine on DHCP and even when I entered a static address such as 192.168.1.61 etc.

Trouble is, I can't get the internet to work at her house on Telstra, can't even ping the gateway.
I have set the static IP address, gateway, mask and DNS server through "Applications - System - Network"
The host setting has "127.0.1.1 mary-desktop" entered.

I know that the Telstra modem is OK as I took my work lap-top around there and was able to surf to my heart's content.

Not so on her machine.

Any help would be much appreciated.

nedkelly
30-05-2010, 03:31 PM
Did you set the right information in the static address?

decibel
30-05-2010, 03:41 PM
Did you set the right information in the static address?

Yes and I know it is correct because it worked fine on my work lap-top.

KarameaDave
30-05-2010, 03:46 PM
Did you restart the network service following the change?


sudo /etc/init.d/networking restart

Here is a manual way to do it.

http://www.ubuntugeek.com/change-ubuntu-system-from-dhcp-to-a-static-ip-address.html

mikebartnz
30-05-2010, 07:14 PM
I have mine set to using Clear
IP Address : 192.168.1.2 This may need changing depending on your router.
Netmask : 255.255.255.0
Gateway : 192.168.1.1 This may need changing depending on your router.
DNS server 1 : 203.97.78.43
DNS server 1 : 203.97.78.44
It is better to set a static IP address.
If you have the network manager running the easiest way is to right click on it and go to configure network.

Agent_24
31-05-2010, 02:15 AM
Is the network adaptor in her machine actually detected etc?

inphinity
31-05-2010, 08:44 AM
What address have you assigned the PC, and what is the routers address? Where does the "127.0.1.1" come from?

Erayd
31-05-2010, 09:02 AM
I have mine set to using Clear
IP Address : 192.168.1.2 This may need changing depending on your router.
Netmask : 255.255.255.0
Gateway : 192.168.1.1 This may need changing depending on your router.
DNS server 1 : 203.97.78.43
DNS server 1 : 203.97.78.44
It is better to set a static IP address.
If you have the network manager running the easiest way is to right click on it and go to configure network.I think we're talking about a direct connection to a TelstraClear cable modem here - the OP has made no mention of routers, which means that the PC should have the public IP set directly.

mikebartnz
31-05-2010, 08:32 PM
Know nothing about setting those up.

decibel
31-05-2010, 09:10 PM
Sorry, yes it is direct to a cable modem.
Originally there was a message on the screen about adding mary-desktop to the hosts file but nothing about what ip address - I worked out it was
meant to be 127.0.1.1 mary-desktop
I have set the public ipaddress as 121.73.148.x and the g/w as 121.73.148.1 and DNS as 203.96.152.4 with secondary DNS as 208.67.222.222 (OpenDNS)

I'll try Karamea Dave's suggestion tomorrow night together with another couple from a geek at work.

Erayd
31-05-2010, 11:32 PM
...I worked out it was meant to be 127.0.1.1...
I think you'll find that should be 127.0.0.1, not 127.0.1.1. Although not having it shouldn't make any difference, that entry is entirely optional unless you're doing something rather strange.

johnd
31-05-2010, 11:44 PM
127.0.0.1 and 127.0.1.1 (and any other valid IP address starting with 127) are loop back addresses - so that will not be correct.

Shouldn't it just work if you put the workstation onto DHCP?

Erayd
01-06-2010, 02:17 AM
127.0.0.1 and 127.0.1.1 (and any other valid IP address starting with 127) are loop back addresses - so that will not be correct.I'm pretty sure the OP was talking about their hosts file, not the network IP address.


Shouldn't it just work if you put the workstation onto DHCP?No - this is a TelstraClear cable connection, they don't use DHCP, and they don't provide routers. Everything on their network gets a static public IP address, which needs to be manually set.

decibel
03-06-2010, 11:53 PM
The problem is now fixed with the following settings -

static ip addr = 121.73.148.x
mask = 255.0.0.0
g/w = 121.73.148.1
DNS = 203.96.152.4 and 208.67.222.222
search domains = "lan" & 203.96.152.12
hosts = "127.0.1.1 mary-desktop" added to what was already there

I am still confused as to -
- why the Telstra installer set the mask as /8
- what exactly the "search domains" field is for and why did the installer put what is one of TC's DNS servers in there
- and why did "lan" pop up after I put "mary-desktop" in the hosts file?

Unfortunately I can't do anymore experimenting as the PC is some distance away and "it's no longer broke"

Thanks guys for the tips.:thanks

Erayd
04-06-2010, 03:10 PM
I am still confused as to -
- why the Telstra installer set the mask as /8?
Because they screwed up - TelstraClear's cable network uses /24 subnets in most locations. Setting this to /8 will cause problems, and result in some 16,776,960 addresses in the 121/8 subnet being unreachable, as the PC will try to contact them directly rather than via the gateway (and will therefore get nowhere).

- what exactly the "search domains" field is for...
This field is for resolving unqualified hosts. If you attempt to resolve an unqualified hostname (e.g. 'frankenstein'), but the host can't be found at the given nameservers, then the system will also try to resolve it as 'frankenstein.searchdomain' - so if you had 'example.com' set as a search domain, then this would resolve the record for 'frankenstein.example.com'.

...and why did the installer put what is one of TC's DNS servers in there?Because they're clueless and screwed up - DNS servers do not belong in the search domain field, they should be listed as nameservers.

- and why did "lan" pop up after I put "mary-desktop" in the hosts file?This doesn't need to be there... Unless you're running a local DNS server on your network that is authoritative for the 'lan' TLD, having 'lan' in this field will achieve precisely nothing.