PDA

View Full Version : MAC password Help



wainuitech
24-05-2010, 11:50 AM
Ok, first to admit, I know naff all about MAC security.

So you MAC users -- HELP!

Customers got a Windows XP home PC with a shared printer over the LAN, the MAC can see it fine, the MAC printer software is installed on the MAC and the printer installed, but the PROBLEM is when ever you go to print it pops up with a user name and password required.

Tried the MAC details -- Not correct ones. The Windows XP DOES NOT have a password to log in, it boots straight into windows. Other windows PC's can print no problems to the share.

How do you turn off the MAC asking for the user name and password when wanting to print.???

I need exact instructions / Path as its going to be emailed to the person.

Dont ask what version of OS, as I dont know, but its only a week old, so I assume its the latest.

:thanks

nedkelly
24-05-2010, 12:02 PM
When connecting to my mac from windows I have to use the following format for user name.
MACHINENAME\Username
or IP\Username

wainuitech
24-05-2010, 01:03 PM
The MAC can see the printer fine - just keep's asking for a password - but there isnt one.

When looking at the print Queue on the MAC it says its waiting for Authentication (but from What) ?? Thast what I need to disable. If it were a windows machine it wouldn't be a problem. But I dont know the security rubbish on MAC's.

Edited: Will this work ? (http://www.macosxhints.com/article.php?story=20070916131935539) -- I dont have a MAC to test it on a Windows PC/LAN.

So much for MAC's "just working with everything"

nedkelly
24-05-2010, 01:33 PM
Yes that is what I had to do with mine, this one is better because it is newer and done on 10.5 http://www.codedifferent.com/2008/06/28/how-to-connect-from-mac-os-x-leopard-to-a-shared-printe-via-a-windows-xp-printserver/

berryb
24-05-2010, 04:49 PM
Did you resolve this?

Are you sure XP doesn't have a password and someone has setup auto logon into the user account? Normally the Mac would ask for this because authentication is being requested.

wainuitech
24-05-2010, 04:59 PM
The persons gone out for the day so I cant test it. But I did check for passwords on the XP PC when there - nothing.

Other Windows pc's print straight away.

Would the fact the Mac is connecting Via wireless have anything to do with it?

Once connected to the wireless its on the Net right away, can see the network shares fine - just wont print without the password.

When loading the printer on the Mac, it didn't ask for any authentication, simply found the windows network, PC, and printer easy as pie.

nedkelly
24-05-2010, 05:01 PM
No, all my macs connect via wireless, I would try the smb://name@host/printer option and see what happens

lakewoodlady
24-05-2010, 05:08 PM
It'll be something to do with the "Keychain" in System Preferences on the Mac. The owner must have a username and password stored in there somewhere. Unfortunately you have to know it in order to be able to disable it.

LL

berryb
24-05-2010, 05:12 PM
Sounds to be a Mac issue. They are not as simplistic as many make out thay are! I deal with them in a mixed Domain enviroment and don't normally have athentication issues.

To eliminate the PC enable Security Logging on the XP box if you can. This way when trying to connet use any username and password and see if it is logged. If it is then XP is requesting athentication.

Also on print server try giving "everyone" full permissions on the printer share. Not just "print". I have had to give "print" and "print management" permissions to users so they ould print for some strange reason.

plod
24-05-2010, 05:18 PM
I can't find the latest guide but have found one from tiger, maybe a little different. here (http://tech.ifelix.net/3015.html)

Have you tried ticking the remember my password in the keychain box?
Wireless won't have anything to do with it

nedkelly
24-05-2010, 05:34 PM
I gave wainuitech a link for a newer one

berryb
24-05-2010, 05:42 PM
Meant to add where I said "If it is then XP is requesting athentication." This would be try if event was a failure.

wainuitech
24-05-2010, 05:50 PM
Thanks folks -- I'll try and get hold of the person tomorrow.

On the link Plod gave (thanks) where it says "You will now face an authentication dialogue." thats where it turns to custard - there is no password on the Windows machines - strangely though it locates the printer fine.

As per Neds link
Problem:
Adding the printer via the standard Apple-way as a windows printer works – but printing does not work because it is not possible to authenticate against the printserver. Thats exactly what happens.

I'll try nedkelly links and suggestions and let you know.

Fingers x- ed.:thanks

jinja_thom
25-05-2010, 02:49 PM
I am having the same problem, on a multi platform Lan from an imac running osx10.5 I can see the printer attached to the windows system but cannot print to it. The print command does not produce an error but nothing appears in the print queue and no print takes place. About 2 months ago it worked but I never use it, I only set it up as an excercise to see if it would work and there have been many updates on both systems since then, now nothing.
As far as authentication goes it's the mac requesting it and a blank password is OK if there is no password for login to osx, it's a bit like the UAC on vista, any time you want to change a significant system setting it asks for username and password even if it is a null password.
I'm still working on getting mine going so I'll post again if I succeed.

jinja_thom
25-05-2010, 05:35 PM
One thing I have discovered about the authentication process is if you get it wrong a couple of times it goes into sulk mode and then even if you get it right it completely ignores you until you restart osx.

jinja_thom
25-05-2010, 11:38 PM
I am trying to connect to an HP PSC 1200 Series and still failing.
I found this page http://support.apple.com/kb/HT1893 which might explain my problem so tomorrow I shall try another printer.

jinja_thom
26-05-2010, 10:58 AM
Today I installed a PSC 2110 all in one on the XP box and because it has a preinstalled driver on OSX it sailed through first try and now prints happily from OSX 10.5.8 I shall now try it from OSX 10.3.9 on an ibook.

nedkelly
26-05-2010, 12:09 PM
I have that model and can tell you it works on panther