PDA

View Full Version : I hate CSS 7 - Getting 2 buttons too line up horizontally



Morgenmuffel
06-05-2010, 12:13 PM
Greetings
Here is the problem (http://nigel.geek.nz/ihatecss7.php), the buttons should be under the comment form however when i get them to work in one browser, they die in another,

all i really care about is getting them to line up horizontally, under the text area

It looks OK in Firefox, but if you look in IE or Opera, the buttons aren't lined up.

I just can't seem to get it to work and i really don't want seperate style sheets, (although one for ie is ok)

Morgenmuffel
06-05-2010, 07:11 PM
and 7 hours later i think i have it.

shown inline here but will be in a style sheet eventually


<span class="butt-space" style="position: relative; left: 0;">
<span style="position: absolute; left: 0;">
<input type="submit" name="submit" id="submit" value="Send" class="button green2" />
</span>
<span style="position: absolute; right: 0;">
<input type="reset" name="reset" id="reset" value="Reset" class="button green2" />
</span>
</span>
and removing the float right from the #reset id
seems to work in all browsers okayish, haven't checked older ie yet


Does CSS make sense to people?, I have read dozens of books and things like the above still baffle me, it takes me for ever to get them to work, whereas tables are dead easy, not that i use tables anymore,

Morgenmuffel
06-05-2010, 07:37 PM
any looked at the page in ie6?

buttons seem invisible

Renmoo
06-05-2010, 07:52 PM
Attached file: ie6.jpg (http://www.imagef1.net.nz/files/ie6.jpg) (192 KB)

Looks all right on IE6.

Renmoo
06-05-2010, 07:56 PM
[Edit] Nvm

Morgenmuffel
06-05-2010, 09:15 PM
Attached file: ie6.jpg (http://www.imagef1.net.nz/files/ie6.jpg) (192 KB)

Looks all right on IE6.
Thats odd, i'm running IE6 in NT4 in VPC and the buttons are invisible

anyway is the hover effect working in any version of IE for you?

as it ain't working here

on a completely different note

I have read that when using the microsoft filters


filter: progid:DXImageTransform.Microsoft.gradient(startCo lorstr='#ffffaa', endColorstr='#4d7432');


you should also include a version prefixed like the below so it will work on IE8, however the above version seems to work fine


-ms-filter: "progid:DXImageTransform.Microsoft.gradient(startCo lorstr='#ffffaa', endColorstr='#4d7432')";


so should i include it?

any way i need sleep or i wil be an even bigger Morgenmuffel tomorrow

Renmoo
06-05-2010, 10:10 PM
Hover effect works upon mouseclick on IE6, IE8

hueybot3000
07-05-2010, 09:00 PM
Try putting the buttons in there own div