PDA

View Full Version : Uniden VS2600XR Car Alarm



wratterus
28-04-2010, 10:24 AM
Got this installed last night in my 2000 Mazda SP20. All functions are working, but around 4 times out of 5 the doors will not unlock. The immobilisers and alarm are switched off, the lights and siren behave normally but the doors don't unlock. If you manually unlock the door it is fine.

Have double and triple checked all the cabling relating to the central locking.

Occasionally, the doors will unlock, maybe work twice in a row and then not work for 10 or 15 times. I'm baffled! :badpc:

The car has no fancy fading lights or any of that paraphernalia, no factory alarm, although it looks like a really basic one had been installed in japan at some stage. Spent a few hours looking around the net last night, wasn't able to find anything. Heaps of problems with the factory immobilisers and alarms playing up, but not aftermarket.

If I get a minute or 20 today I'll call Uniden, see if they have ever heard of this happening before.

If anyone has come across this or a similar issue and has any thoughts on how it might be fixed, I'll buy you a box of beer! :punk

DeSade
28-04-2010, 12:21 PM
Is it all doors or just the drivers door, check if you haven't, the motor on the lock might be failing. I had a similar incident.

wratterus
28-04-2010, 01:17 PM
All doors, including boot. When the drivers door is locked or unlocked manually with the key all doors lock or unlock, so the central locking is working fine.

Phil B
28-04-2010, 02:03 PM
You need to know if an aftermarket central lock solenoid has been fitted in the drivers door. Mazda mostly only have a switch which is operated via mechanical means when the key lock is operated or the knob inside the car is moved. You manually lock the drivers door & the factory central locking to the other doors is triggered via the switch. Do you have a switch in the car that locks & unlocks all the doors including the drivers door when you press it? If you do, it's likely the alarm or electrical connection between the car & the alarm is faulty.
The aftermarket solenoid (if fitted) is operated by the alarm & this moves the mechanical linkage in the door, which in turn triggers the vehicles factory fitted central locking system.
Hope that's not as clear as mud.

wratterus
28-04-2010, 02:21 PM
That's good info thanks.

There is no button in the cabin for locking and unlocking all the doors - the only way to do this is to press down the drivers side lock on the door - this locks (and unlocks when pulled up obviously) all the doors.

Uniden's tech guys said to check that there is an earth pulse going through the unlock wire every time the unlock button on the remote is pressed, I'll check that tonight. If there is, then I'm guessing that I'll need to grab a door lock motor and interface. (I assume this is the same thing as the solenoid you are talking about?)

Can pick up the interface and motor from repco for around $80...

nofam
28-04-2010, 03:00 PM
They do have a remote central locking device fitted though Wrat - I had to buy a new remote for mine when I imported it, but everything else needed was there from factory.

It will also re-lock itself after about 20 seconds if you don't open a door etc once you've used the remote.

wratterus
28-04-2010, 03:05 PM
Intermaresting...there doesn't seem to be any such thing on this SP20, and certainly no auto door locking or anything...will double check though. I'll pop the drivers door panel off tonight and check if there's anything odd going on in there too...it does look like they all came out of the factory with remote locking...although how that would interfere with this is still beyond me.

Phil B
28-04-2010, 08:37 PM
If you have the handbook for the alarm it could have the wiring diagram in it. If so, look for the central locking outputs. I've just had a look at the Uniden AU site & it doesn't look like the VS2600XR has built in C/L relays. If you can access the alarm control unit, probe the C/L output wires with a 12 volt bulb type circuit tester 1 at a time & see what happens. Nothing, it's the C/L system. If it works, the alarm's faulty. It's easier to fix these things if the alarm has been installed by a useless installer. Everything is easy to access.
If you do remove the door trim it's easy enough to see the aftermarket C/L motor that's been installed should it have one

Phil B
29-04-2010, 02:10 PM
Forgot to say to connect the test light to a good earth before probing