PDA

View Full Version : Port forwarding



jcr1
04-04-2010, 12:07 PM
I now have a ThomsonTG585v7 router. One of those ones that Telecom give us when we sign up.
I want to unblock port 80, but I cannot, with this router. And, I've used portforwarding.com, to the letter.
Is there someone who has had experience with this? That could help me (or even tell me, once and for all, that I'm wasting my time).

I've shifted and the DSE XH1169, that worked fine at the other place (and which I port forwarded with - easy), doesn't work here. The ADSL light won't stop blinking and diagnostics indicate ADSL is faulty. Even going back to default and starting again, doesn't help.

Thanks

Trev
04-04-2010, 12:14 PM
Click Here. (http://telecom.custhelp.com/app/answers/detail/a_id/1569/r_id/166/search/1/kw/Thomson)
:)

jcr1
04-04-2010, 01:10 PM
Thanks Trev,

That's about the same as the instructions on "portforward.com".

Still no luck. I'm just wondering whether I have to get assigned a static IP from Telecom (which has to be paid for and I won't do that), rather than the instructions from the above site, which sets an internal ip for the incoming connection to use i.e. 192.168.1.7, and assign dns's (which I do from "opendns").
The other thing could be perhaps, to set up DDNS. I wonder if that would work?

Trev
04-04-2010, 02:56 PM
Could be a problem else where seeming that your DSE XH1169 dose not work. Perhaps someone else can help. A bit out of my realm I'm afraid.
:)

wainuitech
04-04-2010, 05:52 PM
I want to unblock port 80, but I cannot, with this routerIs the port actually blocked in the router or elsewhere. If its in the router, is it simply grayed out or not showing or what is saying its blocked ??

Port 80 is the official port for the internet, http - Can be used for access to/from a server for example.

So if you have a hosting / Web server and want to aim it at the internet, you would redirect port 80 to that servers IP address (normally static IP) If you have a ftp server, usually they use port 21

Some ISP's block port 80.

You can try running canyouseeme (http://www.canyouseeme.org/) - it will tell you what the default ports are and IF you can get through, if not your ISP my be blocking port 80.

An Example (http://www.imagef1.net.nz/files/port_80.jpg) - I'm on Telstra cable, and they are not blocking port 80.

fred_fish
04-04-2010, 07:21 PM
Don't worry about DNS or static IP's or DDNS yet, it is irrelevant until you get your port forward working.
Do one thing at a time.
Follow Trev's guide to forward port 80 to your servers LOCAL ip.
Test by trying to connect to http://YOUR.EXTERNAL.IP.ADDRESS from a machine that IS NOT ON YOUR LOCAL LAN.

Check that the Thompson does not have it's control panel on external port 80.
Check that your local web server's firewall is not blocking inbound traffic.

jcr1
05-04-2010, 11:35 AM
Interesting, when I check port 80 with "portforward.com"'s port checker, I receive an open message, but that is directed to the internal ip (192.168.....).

When I check using the link you gave me I get this "Error: I could not see your service on 222.154........... on port (80)
Reason: Connection timed out"

So, something has worked, and this is what I get from grc.com;

"80
HTTP
Stealth There is NO EVIDENCE WHATSOEVER that a port (or even any computer) exists at this IP address!"

Sounds promising for the rest of the project, thanks for your help so far.

fred_fish
05-04-2010, 05:53 PM
So... you DO have a webserver running on the target machine on your LAN?
You ARE checking it by using a machine outside your LAN?

What are you trying to achieve exactly, by "unblocking port 80"?

jcr1
05-04-2010, 07:27 PM
Use it for some of the remote facilities on my Synology 108j server i.e. photo station, web station etc. Which uses port 80.

I tried it from outside my LAN, didn't work:groan:

fred_fish
05-04-2010, 08:11 PM
OK, so you are wanting to access it from the internet?
Or just from your LAN?

jcr1
05-04-2010, 08:24 PM
From the internet, Fred.

fred_fish
05-04-2010, 08:52 PM
Right.
Presumably the box has some sort of web page for viewing pics, changing settings etc. running on port 80.
Can you connect to it locally?
Does it have any "firewall" settings to restrict access to certain IP's (like your local subnet)?

Agent_24
06-04-2010, 02:42 AM
You are forwarding port 80 to the correct LAN IP address of the Synology 108j ?

Can you post a screenshot of the port forward page of your router as it is now?

jcr1
06-04-2010, 07:29 AM
Right.
Presumably the box has some sort of web page for viewing pics, changing settings etc. running on port 80.
Yes

Can you connect to it locally?
Yes again

Does it have any "firewall" settings to restrict access to certain IP's (like your local subnet)?
No, not that I'm aware of.
:thanks

jcr1
06-04-2010, 07:45 AM
You are forwarding port 80 to the correct LAN IP address of the Synology 108j ?

Yes, as far as I know, it converts to a MAC address.

And here's a couple of screen shots :thanks Agent

http://www.imagef1.net.nz/files/portfwd(1).JPG

http://www.imagef1.net.nz/files/portfwd(2).JPG

fred_fish
06-04-2010, 08:47 AM
Remove the two extra forwards and it shoild work.

Agent_24
06-04-2010, 10:17 AM
If "Diskstation" forwards port 80, what do "Direct Connect" and "web server" rules forward?

jcr1
06-04-2010, 07:49 PM
If "Diskstation" forwards port 80, what do "Direct Connect" and "web server" rules forward?
Just me making a mess of things Agent.

But, I did what you said Fred, and it looks like progress (I hope), as using "canyouseeme", gives me a success message for port 80.

jcr1
06-04-2010, 08:12 PM
I believe I'm there, in part anyway.

When I type in the address, that I got from dyndns, I get this error "Services for this domain have been discontinued".
Close down the PC, but leave the router and diskstation going and connect with my laptop, it works! Which, I believe indicates a loopback problem.

But then turn the PC on and I can still connect with the laptop.
At last, progress:D

jcr1
06-04-2010, 08:36 PM
I just got someone to test it from a remote pc. It works:thumbs:

Agent_24
06-04-2010, 10:41 PM
Good to see you got it working :)