PDA

View Full Version : ALT key gone crazy



Alistar3000
27-03-2010, 10:16 PM
I'm having problems with the ALT key on my keyboard - the left key seems to now only turn mute on and off (unless I press it quickly twice and then it makes the PC hibernate) and the right key shuts the PC down.

Any ideas on what's causing it, and how I get my ALT keys back?

Thanks

wainuitech
27-03-2010, 10:46 PM
Welcome to PF1.

Go into the control Panel, (Start/Control Panel) look for regional settings, check to make sure the Region is set to English- NZ or US.

What OS are you using ??

Renmoo
27-03-2010, 11:08 PM
Is that the only key that has gone haywire?

Alistar3000
28-03-2010, 08:46 AM
Sorry, should have added a bit more info.

All the other keys seem to be working fine, it's only the 2 ALT keys. I'm using Windows XP and have checked the regional settings, which are set to English NZ. I have also tried uninstalling the keyboard and reinstalling it.

The only changes I have made to my PC recently have been to add a USB hub and installed Company of Heroes (with all the patches).

The problem may have existed before then, but I only noticed it yesterday when I tried to use the ALT key to move the camera in Company of Heroes and my computer shutdown on me.

Driftwood
28-03-2010, 08:51 AM
Is this a USB keyboard & is it running through a hub?

Alistar3000
28-03-2010, 08:53 AM
Nope, it's not a USB keyboard, just a normal keyboard plug, plugged directly into the back of the PC.

Also, if I've got IE open and I press the left key, sometimes /gh appears in the address bar, or any text fields, and sometimes '0 appears, if that means anything..

Thanks.

Driftwood
28-03-2010, 08:58 AM
Can you try another keyboard.

wainuitech
28-03-2010, 08:58 AM
Sounds like the Alt keys have remapped somehow.

Do you have any software for that keyboard installed, example my Logitech Wave keyboard has its own software.

Go into the control panel keyboards, look throughthe settings, see if there is anything to set defaults.

zqwerty
28-03-2010, 08:59 AM
Try another keyboard

Alistar3000
28-03-2010, 09:17 AM
I don't think there's any software for the keyboard - it's just a generic DSE keyboard. I do have a disc of drivers but none of them seem to match up to the keyboard.

Looks like I'll have to track down another keyboard to try..

Thanks for your help.

Renmoo
28-03-2010, 11:19 AM
Otherwise you can download a keyboard remapper and remap the Alt keys to the correct settings instead. :)

Paul.Cov
29-03-2010, 06:34 AM
I've seen behaviour similar to this on Dell machines that are repeatedly hibernated. Have you tried the basics of a complete shutdown (no power, no lights, no fans, dead) and then restart?

Alistar3000
29-03-2010, 09:13 AM
I have tried a complete shutdown - in fact the only time I have ever used hibernate is over the weekend when the left ALT key would cause hibernation.

I've tried a new keyboard and that seems to work with no problems, so I guess I'll just get rid of the old keyboard.

Thanks for all the help and suggestions.

Cheers.