PDA

View Full Version : How to prevent embedded videos from auto start?



mzee
25-03-2010, 09:12 AM
If I embed a video from a file on my web site, in a web page it starts as soon as the page is opened which slows down the loading of the page. How can I stop this?

If I embed a video on line from U tube, it waits for you to start it.

bevy121
25-03-2010, 11:07 AM
what type of file/player is it?

for example, a windows media player one would have something like

<PARAM NAME="AutoStart" VALUE="False">

in the embeded code to have it not play

mzee
25-03-2010, 08:12 PM
Found the answer:-

<OBJECT ID="MediaPlayer" WIDTH="192" HEIGHT="190" CLASSID="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
STANDBY="Loading Windows Media Player components..." TYPE="application/x-oleobject">
<PARAM NAME="FileName" VALUE="videofilename.wmv">
<PARAM name="autostart" VALUE="false">
<PARAM name="ShowControls" VALUE="true">
<param name="ShowStatusBar" value="false">
<PARAM name="ShowDisplay" VALUE="false">
<EMBED TYPE="application/x-mplayer2" SRC="videofilename.wmv" NAME="MediaPlayer"
WIDTH="192" HEIGHT="190" ShowControls="1" ShowStatusBar="0" ShowDisplay="0" autostart="0"> </EMBED>
</OBJECT>

Suits all occasions.

pcuser42
25-03-2010, 08:15 PM
You do have to specify this, as the default is false on Internet Explorer, but true in every other browser. (Or is it the other way round?)

bevy121
26-03-2010, 10:30 AM
glad you found the answer :rolleyes:

Isnt that what I said?

pcuser42
26-03-2010, 02:50 PM
glad you found the answer :rolleyes:

Isnt that what I said?

Not the first time it's happened ;)