PDA

View Full Version : USB "unknown device" all of a sudden



GeneralKanos
10-03-2010, 10:46 AM
Hey guys,

Im trying to fix a friends PC, well, digital camera really.

All of a sudden when she plugs the camera in to dl the photos, a yellow device pop up box comes up saying the "USB Device is not recognized".

In device manager it appears as "unknown Device"
Ive tried uninstalling and reinstalling; Ive put the cd and installed all the software; Ive even turned the computer off and left it disconnected from power for a few min.
When I try to reinstall the driver it tells me that it couldn't find a better match for the hardware than the software already installed (which is nothing, as no driver is installed)

Other devices such as mice etc all work, and the thing that stumps me is that it WAS working but now is not, so its prob not a power problem.

Any help appreciated,

GK

Speedy Gonzales
10-03-2010, 11:09 AM
What version of windows? Have you tried deleting all the entries under USB contollers in device manager, then rebooting?

KarameaDave
10-03-2010, 11:12 AM
Does the camera work on other PCs?
If you can't sort it quickly they could try a card reader
as a temporary workaround.

Agent_24
10-03-2010, 04:28 PM
If the camera doesn't work in other computers, try swapping the cable, it might be broken.

Speedy Gonzales
10-03-2010, 04:38 PM
Or like KD said, buy a internal or external card reader. Then you wont have to worry about cables

Agent_24
10-03-2010, 04:48 PM
I'm sure that will help work out if their camera is broken or not...

SolMiester
10-03-2010, 04:51 PM
I have had similiar issues before with USB devices, the registry entry gets corrupted. There are 2 fixes, freash install of the o/s or deletion of the registry entries, reboot and the device will connect with new entry..

I dont have the link, so you will have to look up USB device registry corruption or something...

KarameaDave
10-03-2010, 05:28 PM
My first question is designed to
eliminate camera and cable from the equation.
My workaround is not, it is just a stopgap!
The problem, most probably, as almost always it is,
will be our old friend,
Windows.

GeneralKanos
11-03-2010, 02:07 PM
The PC is running XP SP2.
The Camera runs fine on my machine, but she's using a usb extender so ill try eliminate that.
Unfortunately this all has to wait till the next time I go over there T__T.

ty for that, Ill look up how to delete the USB registry now.