PDA

View Full Version : Map 'Remote' Network Drive over Internet



babip
24-02-2010, 12:49 PM
I am at my office and get in to my home machine via Remote Desktop - no problems.
How do I Map my home computer drive (eg: DVD Drive or Shared Folder) in to my office computer ?

nedkelly
24-02-2010, 01:18 PM
That would not be very secure. I would recommend if you do try it you do it over a VPN.

wainuitech
24-02-2010, 01:24 PM
Just about to say that :lol: you are safer off setting up a VPN first, then mapping Via that.

Whats the OS ?? Windows 7 has a easy wizard to work through VPN setting up.

This site (http://compnetworking.about.com/od/vpnsetup/VPN_Setup_How_to_Set_Up_a_VPN.htm) has a lot of articles on setting one up.

babip
24-02-2010, 01:28 PM
Is it relatively simple to setup ?I have not done it in past ?

nedkelly
24-02-2010, 01:28 PM
you will also need to forward a port to your computer but im not sure which one, but some one else here must.

inphinity
24-02-2010, 01:31 PM
You will need to forward port 1723 as well as the GRE protocol to whichever device is the VPN endpoint, assuming you will use PPTP.

nedkelly
24-02-2010, 01:33 PM
will babip also need to forward the port for file sharing to his computer?

babip
24-02-2010, 01:37 PM
You will need to forward port 1723 as well as the GRE protocol to whichever device is the VPN endpoint, assuming you will use PPTP.

Means I open the port 1723 and forward it my computer ip address ?
eg: PPTP 1723 -- > 192.168.1.xxx ?

inphinity
24-02-2010, 01:40 PM
will babip also need to forward the port for file sharing to his computer?

No.


Means I open the port 1723 and forward it my computer ip address ?
eg: PPTP 1723 -- > 192.168.1.xxx ?

Correct, assuming your computer is receiving the incoming VPN connection. You must also allow PPTP passthrough, or PPTP forwarding, or whatever terminology your router uses to mean "Let VPNs work".

nedkelly
24-02-2010, 01:40 PM
yeah. Make sure you give your computer a static ip address or the forwarding will not work, (forgot about that myself for my first forwarding).
You will also need to set up something like Dynamic DNS if you dont have a static public ip address.

babip
24-02-2010, 01:42 PM
I have following Enabled by Default in my Router.
IPSec PassThrough:Enable
PPPoE PassThrough:Enable
PPTP PassThrough:Enable
L2TP PassThrough:Enable

ALSO

I have forward port to
PPTP 1723 -- > 192.168.1.xxx

wainuitech
24-02-2010, 01:49 PM
Done it a couple of times in the past --BUT it was a long time back, cant remember all the steps fully off the top of my head, but it was to a server that the Admin guy had already setup to allow VPN - thus he gave me the user name and password.

Never tried This (http://www.online-tech-tips.com/software-reviews/hamachi-create-your-own-personal-virtual-private-network/) - but looks easy enough.

inphinity
24-02-2010, 01:52 PM
I have following Enabled by Default in my Router.
IPSec PassThrough:Enable
PPPoE PassThrough:Enable
PPTP PassThrough:Enable
L2TP PassThrough:Enable

ALSO

I have forward port to
PPTP 1723 -- > 192.168.1.xxx


Now you need to configure the PC to accept incoming VPN connections.

babip
24-02-2010, 01:57 PM
1) Home PC is configured to accept incoming VPN connections.
2) Office PC is configured to dial in to home connections
now ?

babip
24-02-2010, 01:58 PM
Worth Mentioning here is...
Home computer = Windows XP sp3
Office computer = Windows Server 2003 r2

SolMiester
24-02-2010, 02:05 PM
Just about to say that :lol: you are safer off setting up a VPN first, then mapping Via that.

Whats the OS ?? Windows 7 has a easy wizard to work through VPN setting up.

This site (http://compnetworking.about.com/od/vpnsetup/VPN_Setup_How_to_Set_Up_a_VPN.htm) has a lot of articles on setting one up.


I would also say he is better off creating the VPN before using Remote Desktop Connection period.

SolMiester
24-02-2010, 02:11 PM
I dont think xp sp3 has the ability to setup incoming VPN connections, only outgoing VPN, it is a client, not server.
The OP will have to have a router which he creates the VPN connection too. Juniper, Cisco

nedkelly
24-02-2010, 02:21 PM
no it can accept them. Have to create new advanced connection and then select incoming

babip
24-02-2010, 02:24 PM
Hey guys I can get up to this stage .. i try and try again and fail with this error.
here (http://pressf1.pcworld.co.nz/attachment.php?attachmentid=1165&stc=1&d=1266974567)

SolMiester
24-02-2010, 02:34 PM
no it can accept them. Have to create new advanced connection and then select incoming


Ummm, no, that for direct connection...ie serial, parallel....only server can accept incoming VPN connections!

nedkelly
24-02-2010, 02:40 PM
http://www.zdnetasia.com/insight/network/0,39044847,39050037-39000223c-1,00.htm

Speedy Gonzales
24-02-2010, 02:43 PM
Hey guys I can get up to this stage .. i try and try again and fail with this error.
here (http://pressf1.pcworld.co.nz/attachment.php?attachmentid=1165&stc=1&d=1266974567)

from here (http://www.tomshardware.com/forum/145635-45-error)

FIXED: Error 733 or lost internet connection when connecting a VPN

Problem:
Internet connection is lost when connected to a Virtual Private Network (VPN).
The following error may also be reported when trying to connect a VPN:
Network Protocol Connection Result
One or more requested network protocols did not connect successfully.
TCP/IP CP connected successfully.
IPX/SPX or compatible CP reported error 733: A connection to the remote computer could not be completed…

Solution:
The solution to this problem is to change the “Use default gateway on remote network” setting. To do this, follow these steps:
1. Open the Network Connections Control Panel
2. Open the VPN Connection’s Properties Dialogue Box
3. Open the Advanced TCP/IP Settings Dialogue Box
4. De-select “Use default gateway on the remote network”
5. Click OK to save settings and close the various open windows

Now Connect the VPN (disconnect and re-connect if it was already connected) and the problem should be solved. Or use teamviewer. It'll probably be easier to figure out

babip
24-02-2010, 02:56 PM
http://www.zdnetasia.com/insight/network/0,39044847,39050037-39000223c-1,00.htm

Voila....
This worked.
I am connected to my network drive now.. ah ha...
nice job every one...
I always keep saying ..
You Guys Rock ...:punk
Super...

SolMiester
24-02-2010, 02:56 PM
http://www.zdnetasia.com/insight/network/0,39044847,39050037-39000223c-1,00.htm

Eh?....my apologies....however, whats with the LPT1 connection?, surely the NIC is the interface? It doesnt explain why?

babip
24-02-2010, 02:57 PM
Speedy.. I try the solution you mention in the link .. unfortunately that did not work.

nedkelly
24-02-2010, 03:09 PM
yeah you leave it unticked and then it asks about virtual networking