PDA

View Full Version : quotemarks mistype in Windows 7



argus
20-02-2010, 06:08 AM
Trivial but annoying problem. In my Windows 7 environment, when I type a quotemark (' or ") in MS Word or on the web, the keyboard doesn't immediately respond; it only delivers the quote when I type the next character.

That's if the character is a consonant. If the first char after " is a vowel I get that vowel with two dots over it (umlaut or dieresis).

I was using a comfortable old wireless keyboard that has never given this trouble before, so I figured it had to be my new Windows 7 desktop. Just to be sure it wasn't some strange incompatibility, I unplugged the wireless device and connected the keyboard that came with the machine; problem persists.

Close Windows and reboot into Ubuntu - no quote problem.

So looks like it's definitely a mis-setting in Windows 7. How do I fix it? Keyboard in Control Panel just gives me irrelevant things like repeat-rate; tells me nothing about the character-set.

Thanks.

Agent_24
20-02-2010, 06:33 AM
I have had this exact same problem, but I have no idea what causes it

KarameaDave
20-02-2010, 07:13 AM
You might have US International as your keyboard type.


"Anyway, using the US International layout will delay the effect of the '
and " keys (among others) to let them be combined with other keys. To
get the original keys you have to press space after them, eg quote-space "

from here

http://lists.scribus.info/pipermail/scribus/2008-January/028271.html

Safari
20-02-2010, 07:35 AM
You might have US International as your keyboard type.


"Anyway, using the US International layout will delay the effect of the '
and " keys (among others) to let them be combined with other keys. To
get the original keys you have to press space after them, eg quote-space "

from here

http://lists.scribus.info/pipermail/scribus/2008-January/028271.html

More info at this link with info on how to change to US instead of United States-International keyboard layout.

http://support.microsoft.com/kb/306560#3

Agent_24
20-02-2010, 08:14 AM
Looks interesting... Though I never have chosen US International keyboard - at least not on purpose or that I know of..

If I notice this problem again, I will check this setting... :thumbs:

argus
20-02-2010, 04:06 PM
Thanks: quotes now “good” even “awesome”; “umlautery” has ceased.

KarameaDave
20-02-2010, 04:43 PM
"Happy to hear it"

Shortstop
20-02-2010, 09:53 PM
Amen to that. I thought I was the only obne affected. Thanks safari. so easy when you know how!

mzee
20-02-2010, 10:32 PM
I had a similar problem with XP recently. '#' became '£', '@' became ' " ' , ' " ' became '@'.

The cause was that it was set for an English keyboard.