PDA

View Full Version : Netowrk Sharing Win 7 & Vista



GorCh
16-02-2010, 09:59 PM
Hi there,

Having problems with sharing folders over my home network. I am running Win7 64bit, and my flatmate is running Vista 64.

In Network & Sharing center, network discovery, file and folder sharing are turned on. Password protected sharing is off.

If I right click on any folder in my account, and go Properties>> Sharing>>Share, and select to share with Guest (with read/write permission level) my flatmate can see the files but cannot copy them to his PC. Instead he gets an error "Need permission to perform this action."

However if he does the exact same process to any of his folders I can copy his share happily.

I have looked over the place for solutions to this, but all the guides for sharing seem to think that this should be working fine.

Your help is much appreciated.

GorCh

wainuitech
16-02-2010, 10:29 PM
When you go into the Sharing tab on the folder - Advanced Sharing - Permissions - Make sure there are ticks in all three boxes ( Full Control, Change & Read) Example (http://www.imagef1.net.nz/files/Example1266312698.jpg)

GorCh
17-02-2010, 10:36 AM
Was set up like that already. Redoing it didn't do anything.

I have just noticed that my Profile folder (Users/Chris) has a padlock icon next to it.

Attached file: Users_Folder.JPG (http://www.imagef1.net.nz/files/Users_Folder.JPG) (30 KB)

Could this have any affect?

Speedy Gonzales
17-02-2010, 10:44 AM
In Win 7 share the folder (one you create NOT a system folder), then select share (the top option not the option WT posted),, select everyone then add, then change it to read/write. The profile folder has nothing to do with it. And kill Homegroup in Win7. You cant use it, there's no point in having it enabled

fred_fish
17-02-2010, 11:39 AM
I have just noticed that my Profile folder (Users/Chris) has a padlock icon next to it.

Could this have any affect?

Sounds like you chose 'Private Home Profile' (or whatever it's called in 7) when setting up your user.

This removes READ access for all other users and is probably what is wrong.
Set the permissions ('file' not 'share' permissions) on the shared folder to include read (at least) access for Everyone.

YMMV as Win7 may think it knows better ....

wainuitech
17-02-2010, 11:46 AM
the top option not the option WT posted That was the second part of sharing, the original post said the first part of sharing was already done.
If I right click on any folder in my account, and go Properties>> Sharing>>Share, and select to share with Guest (with read/write permission level) my flatmate can see the files but cannot copy them to his PC. Instead he gets an error "Need permission to perform this action."often if you dont share with both options, then folders wont share correctly. This applies more to Vista than W7. This is using more of Server 2003 technology than XP's simple file sharing.

GorCh
17-02-2010, 11:47 AM
No luck there sorry speedy. Added 'Everyone' to the allowed people, changed it to read write.

When try to access form Vista get this message;

Attached file: Capture1266360350.jpg (http://www.imagef1.net.nz/files/Capture1266360350.jpg) (28 KB)

wainuitech
17-02-2010, 11:51 AM
What about This One (http://www.imagef1.net.nz/files/This_one.jpg).

GorCh
17-02-2010, 11:52 AM
Yea on as well.

Speedy Gonzales
17-02-2010, 12:10 PM
So the only prob youre having is Vista cant access Win 7's folder (a folder you created)?

But you can access the folder in Vista from Win7?

Get teamviewer, if you want. And I can check it out

GorCh
17-02-2010, 12:19 PM
So I give you the wait for session code?

Speedy Gonzales
17-02-2010, 12:22 PM
The ID and password, send it to me in a PM

GorCh
17-02-2010, 12:38 PM
Ok so with speedy's help it now works. Had to share the folder one level up from the folder i wanted to share. Strange. Cheers for the help everyone.

Speedy Gonzales
17-02-2010, 12:41 PM
No worries