PDA

View Full Version : Windows 7 Control Panel Icons



pctek
21-01-2010, 04:31 PM
Having been playing around with modems lately I found it massively annoying not to have Network Connections available in Control Panel.
Network Sharing Centre is just NOT useful.

So here's a fix to get it back (along with some other icons too if you like).
Add Network Connections icon to the Control Panel

1. Click Start, type regedit.exe and press ENTER

2. Navigate to the following branch:
HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Control Panel \ donít load

3. In the right pane, right-click ncpa.cpl and choose Delete

4. Exit the Registry Editor.

In fact delete whatever you want to show in Control Panel.

wainuitech
21-01-2010, 05:16 PM
Problem --- Even running as Administrator Error message (http://www.imagef1.net.nz/files/reg.jpg)

Its only one more click to get the Adapter ;) - here tis (http://www.imagef1.net.nz/files/Adaptor.jpg) Top left.

OH BTW Genius GM56K PCI-LA modems work first time in W7 with default drivers - just finished one yesterday.

Speedy Gonzales
21-01-2010, 05:27 PM
Go into permissions (under don't load),and take ownership / allow full control. Then it should

wainuitech
21-01-2010, 05:41 PM
Nope still wont let me do anything.

Dont know if its because I'm using W7 ultimate or not ??

Might try on a lower version of W7. To be honest I have never had to fiddle with the LAN settings once set, even on customers PC's.

Speedy Gonzales
21-01-2010, 05:44 PM
So, you highlighted don'tload / right mouse / permissions / highlighted your name / advanced / owner tab / your name / replace owner down the bottom? Then OK. Then tick full control / OK?

wainuitech
21-01-2010, 06:05 PM
Just tried it on a W7 Home premium and it worked OK, Ultimate still threw a wobbly :lol: Might play around with it at some time and find out why.

Still only means one less click to a feature that once set "shouldn't" need a lot of time fiddling with.

Thats half the problem - some people fiddle with settings and stuff things up nicely, esp when they have no idea what they do.

pctek
21-01-2010, 06:38 PM
Nope still wont let me do anything.

Dont know if its because I'm using W7 ultimate or not ??
.

:D

Now surely I don't have to tell you how to fix that?

;)
It did it to me (using Pro) but I sorted it in a couple of clicks. And no not what speedy said.......

I detest the way MS hide things from you that they think you don't need. I don't care about the long way to get there, I needed to click in and out without messing around. Simple, get the icon back.

Most of you won't cause most of you wouldn't have any reason to switch between dialup and LAN connection properties.

nmercer
21-01-2010, 07:21 PM
my work around to this is

whenever I want to look at my NICs, I just go

start
run
ncpa.cpl

wainuitech
21-01-2010, 07:29 PM
The way today has gone with one particular heap of crap HP / COmpaq :mad: :angry its a wonder it hasn't gone out the door yet (with it closed) - so thinking straight is not on the to do list :lol: Damn thing says Blank CD's are not Blank, says it has a Nvidia Graphic Card, when its clearly a ATI, OS - one minute its NTFS, next its FAT32, then back again :waughh:

So "playing" with the reg on my main PC is not a good idea me tinks.


I wont be making it visible to customers -- Hands up how may times techs have gone to a place and Mr NOBODY has been in the settings :clap

PS: heard a damn good one yesterday about some so called help desks. Thats another story / thread.

pctek
21-01-2010, 09:16 PM
crap HP / COmpaq :mad:

So "playing" with the reg on my main PC is not a good idea me tinks.



Chicken.
Come on, it's not a major change. Back it up first. I would imagine you have the thing imaged anyway.

OK, what I did was Take Ownership and ticked Full Control, still whinged.
So then I went into the permissions tab and ticked me, ticked Include Permissions here too (full Control).
It then let me remove all sorts of exciting stuff.
:D:thumbs:

Control Panel is so much more interesting now.