PDA

View Full Version : sapphire HD5770 core clock won't go above 400MHz...



powerover
17-01-2010, 08:24 AM
Hi there everyone thanks for reading this :D

Problem is that I bought a new graphic card which is the Sapphire HD5770, its core clock is at 850MHz max at default settings. But mine won't go above 400MHz.. :badpc: same with the memory, is has a default max at 1200MHz, but won't go above 900MHz..:badpc:

at idle the clock will go down to just 157MHz, when I fire up some HD movies, it will jump to 850MHz for a split second, then back down to 400MHz..:badpc:

I have the latest display driver installed, win 7 pro 32bit, asus p5q pro turbo with the lates bios, and msi afterburner installed to monitor the card.

I was poking around with the windows graphic adaptor settings, found that this card has a "internal DAC type of 400MHz", now is this what is limiting the core clock to a max of 400MHz? I have a strong feeling that this is not the cause of the problem.


Could it be a drivers issue? or anyother settings in the mobo or catalist control center I have missed? How am I going to solve this problem?

the 400MHz core clock is soooo slow I can't even play HD movies, it looks horrible with lime green and purple blocks everywhere ....:badpc:


Any help or guidance will be greatly appreciated, thanks a lot

whellington
17-01-2010, 08:33 AM
What program are you using to text the max load of the card?

Run ATI artifacting tool, if the GPU doesn't go to 850mhz or max load its probably a driver issue

Also download gpuz to see if the card is overheatiing/at max load

http://www.techpowerup.com/atitool/

http://www.techpowerup.com/gpuz/

powerover
17-01-2010, 08:38 AM
What program are you using to text the max load of the card?

Run ATI artifacting tool, if the GPU doesn't go to 850mhz or max load its probably a driver issue

Also download gpuz to see if the card is overheatiing/at max load

http://www.techpowerup.com/atitool/

http://www.techpowerup.com/gpuz/

Hi there thanks for the reply.

I use 3dmark vantage to do it....because the core clock won't go above 400MHz the HD5770 has a score of 2870, and my old 250GTS can do almost twice that...:badpc:

will try that tool to see if it can maxout the core clock.

the card is definitely not overheating, it never got close to 40 degress, under 3dmark vantage testing.:badpc:

trinsic
17-01-2010, 02:05 PM
It will only ever run full speed when it needs too. Run a 3D application like furmark and see what it does then (run in windowed mode so you can see the ATi panel).

powerover
17-01-2010, 02:25 PM
It will only ever run full speed when it needs too. Run a 3D application like furmark and see what it does then (run in windowed mode so you can see the ATi panel).

I think doing a 3D mark Vantage GPU test will require it to run at full speed?? I ran that in windows mode and I can see the core frequency is only at 400MHz. :( :annoyed:

pctek
17-01-2010, 04:47 PM
But mine won't go above 400MHz.. I can't even play HD movies, it looks horrible with lime green and purple blocks everywhere ....:badpc:



Blocks? Then it's faulty. Take it back.

pablo d
17-01-2010, 10:57 PM
what happens if you manually set the core speed higher in CCC?

and you're right it has nothing to do with the 400MHz RAMDAC freq.

inphinity
18-01-2010, 08:37 AM
Blocks? Then it's faulty. Take it back.

Not necessaraily. If I am understanding him correctly he is saying he gets purple/green blocks when playing HD movies, which can often occur if there is a driver or codec error or unsupported hardware for playing back these movies.

If this is the only time the blocks occur, and not when really pushing the card in 3D, it is still possible it is faulty (especially given other issues) but is far from a sure sign.

powerover
21-01-2010, 07:27 AM
Thanks for the reply guys.

I have fixed the problem.

first install catalyst display 9.12 hotfix.

then create a profile in the catalyst control, but dnt activate it, "tweak" that profile, manually setting the 2D clock. then activate that profile, restart the computer.

problem gone.....:D