View Full Version : Firefox + Foxit PDF Reader extension

09-01-2010, 05:08 PM
Dear all,

Has anyone encountered the situation where Firefox, in midst of loading a PDF file, pops up the message "The program is not responding" and with the options to "Switch To" or "Retry"? I find this really annoying as clicking on either of the two options will solve the problem only when the PDF file has loaded, but I can't figure out whether the PDF file has been loaded without clicking "Retry" repetitively.


Speedy Gonzales
09-01-2010, 05:09 PM
It works fine here. But, sometimes it takes its time loading the PDF ! I havent come across the not responding, or retry message tho

09-01-2010, 05:22 PM
This is odd - I can't replicate the problem right now.

09-01-2010, 07:17 PM
This is odd - I can't replicate the problem right now.

If you have Win7 you can use the problem steps reporter if you get the same problem again.

09-01-2010, 07:28 PM
No problems here on XP home 32bit or Win7 64 bit

09-01-2010, 08:14 PM
I have firefox and foxit.

Any particular site and pdf?

09-01-2010, 11:52 PM
I've never had that issue here but like Sweep said, any particular slide or really big PDF's?

10-01-2010, 12:20 AM
I just realised one thing - the problem only arises when I open a PDF file in the browser which hasn't opened any other PDF files yet. Just now when I tried to replicate the situation, my browser already had several PDF files loaded, hence when I experimented with loading more PDF files, the problem ceased to appear.

10-01-2010, 12:24 AM
I have firefox and foxit.

Any particular site and pdf?
The problem applies to all PDF files from all sites

10-01-2010, 10:30 AM
Its a well known problem with Fire Fox and Foxit Reader -- Fire Fox doesn't like the addin -Using IE or Lunascape never had the problem.

Its opening the PDF in FF that causes the problem, if it were downloaded then opened you'd find it opens fine.

I have several times had the same thing - each time its when using Fire Fox (in W7) - Foxit are working on the problem so their forums say.

One way I managed to keep the problem to a minimum, is this -- May or may not work for you.

Open Foxit Reader > help> Check for updates, make sure its all upto date with any fixes, THEN in the update window, click on Preferences, and untick "automatically check for updates" -- I have found that it happens more when its checking for updates & using FF.