PDA

View Full Version : Cannot Start Automatic Updates & BITS Service:SOLUTION



katharinem
28-12-2009, 06:05 PM
An addendum to a previous post re help with a Hijack This log.
I did various scans as advised then searched a bit more and found the following which I tried. It worked. Rapt!

LINK: http://www.burchwords.com/archives/1240.

"Hijackthis reported these two entries that didn’t seem legit:

O23 – Service: Automatic Updates (wuauserv) – Unknown owner – C:\WINDOWS\
O23 – Service: Background Intelligent Transfer Service (BITS) – Unknown owner – C:\WINDOWS\
I found this article on experts-exchange with a guy with a same problem. I searched long and hard and still no dice. I finally stumbled across a little google groups thread with this advice. Make sure you backup your registry before you attempt this. Also, good idea to do a system restore check point.
Solution:
start —> run —> regedt32.exe
Do a search for %fystemroot%
If you find any hits, first change the permissions on the folders so you can edit the registry entry.
change %fystemroot% to %systemroot%
press F3 until you find all entries and repeat step 4.
Try to start BITS and Automatic Updates

The orginal quote from the google group’s thread:

SOLUTION FOUND:
In my registry, the virus had replaced “%systemroot%” with “%fystemroot%”
in several spots, so the correct files could not be found. I did a search
for “fystemroot” in regedit, and replaced with “systemroot”. (I did have to
click “Edit” / “Permissions” and allow full control in each of the folders
first. Evidently the virus disabled the permissions first.) I hope this
helps anyone else who has a similar issue."

I rebooted as well.
Thanks for the help and advice from F1 as well.