PDA

View Full Version : Vista SP2 install taking a long time



Tony
11-12-2009, 11:51 AM
One of my SeniorNet students has just phoned me in a bit of a panic. Her laptop is installing Vista SP2 (why now and not a long time ago when it first came out? - dunno). Anyway, it started, and has been going for a couple of hours with nothing apparently happening apart from the "installing updates" screen. The disk light is flashing, so it would seem like something is happening. I installed SP2 ages ago, so I've forgotten the details, so questions:

Does it show a progress bar?

My feeling is that she shouldn't just turn the laptop off and try again - but is there a cancel option?

Any other suggestions about what might be happening / what she can do?

Speedy Gonzales
11-12-2009, 11:54 AM
It may depend on HOW fast the computer is, she's installing it on, on how long it takes. If its over 1/2 way, it probably wont let her cancel it. But I wouldnt just turn it off

wainuitech
11-12-2009, 12:03 PM
Normally it appears to be installing quick, there is usually a progress bar that gets to around 2/3rd's of the way then appears to stop. I have seen it stay at this point for a couple of hours - generally if you look at the HDD activity light it will be flashing or on solid, generally this means it's dong something.

Stopping it at the wrong time (Force shutting down) will cause all sorts of problems.

Tony
11-12-2009, 12:04 PM
It may depend on HOW fast the computer is, she's installing it on, on how long it takes. If its over 1/2 way, it probably wont let her cancel it. But I wouldnt just turn it offIt is obviously not brand new as it doesn't have SP2, but I don't think it is that old, so I would not expect CPU power to be a major factor.

I agree about not just turning it off - but I thought I'd check.

Do you know if there is a progress bar? As far as I know it hasn't restarted at all - although she may not have been around to notice.

Tony
11-12-2009, 12:30 PM
Normally it appears to be installing quick, there is usually a progress bar that gets to around 2/3rd's of the way then appears to stop. I have seen it stay at this point for a couple of hours - generally if you look at the HDD activity light it will be flashing or on solid, generally this means it's dong something.

Stopping it at the wrong time (Force shutting down) will cause all sorts of problems.That sounds very much like what is happening here. I think I'll give her a ring and emphasise about not turning it off.

I'll report back later.

Scouse
11-12-2009, 12:47 PM
From memory... there were three segments of SP2. Each has a progress bar. One and two installed and then the system restarted before the automatic installation of three.

Tony
11-12-2009, 04:59 PM
All solved, I think. It seems that somehow she had managed to hide the first "SP2 will do all this stuff" dialog behind the windows update window, and so it has been waiting for a response for the last 8 hours! She could actually see a bit of the other window, but being a total newbie, it didn't occur to her that that might be relevant. Once I started getting down to detail with her on the phone about what she could see and what she could do it all came clear.

After a couple more dialogs, she now has a progress bar moving along nicely, and the next thing I expect to hear from her is that it has all finished.

Thanks everyone for all the suggestions.

wainuitech
11-12-2009, 05:00 PM
:lol: The ol hidden window - press next trick. Been caught out with that a few times as well.