View Full Version : Yahoo Xtra Search Box and Google search

10-11-2009, 12:09 PM
Every time I open my Firefox Browser and type a query into my toolbar Google search box, my Yahoo Xtra search box tries to steal it! I end up with half the query in one box and the rest of it in the other. My homepage is Yahoo Xtra, and I have checked the About:config in Firefox options which shows the default search as Google.

Is there a fix for this?

10-11-2009, 12:11 PM
Welcome to PressF1. Is the Yahoo! toolbar installed? If it is, remove it, it's a heap of junk. Click on the icon to the left of the search box in FF and go to manage search engines. Make sure Google is default there and remove any Yahoo! stuff. If you want the Yahoo! toolbar for quick access to mail or whatever, you could just create a shortcut to it on the bookmarks toolbar, or set mail.yahoo.com as one of your home pages.

10-11-2009, 01:56 PM
Thanks. I've deleted the Yahoo! toolbar, and made sure that Google is default in FF in the manage search engines.

However, the cursor still shows under the "Web Search" box in the Yahoo Xtra home page after the home page is fully loaded.

It appears that the Yahoo Xtra home page overrides any default as far as the search engine is concerned.

One of the Yahoo Xtra options is to have a small or large web search box, but it appears that it cannot be deleted as it is hard-coded. If only I can divert the cursor and focus it elsewhere.

10-11-2009, 02:22 PM
Ah ok, so it's the actual search on the Yahoo home page. I don't know of any way around that short of changing the home page. Google does it too.

10-11-2009, 02:52 PM
When the page loads, the default input box on the page gets selected. This'll happen to pretty much any search engine site - google.com etc. Just wait for the page to load, then click in the Google toolbar search box, or change your home page.

10-11-2009, 03:07 PM
Thanks both of you for your replies. I don't recall it happening until just recently.

However, yes, I'll either have to wait for the page to fully load or I may change my homepage to overcome it.

Thanks again.