PDA

View Full Version : Can't log off win 2k3 console session



FAB
23-10-2009, 10:30 AM
Morning all

Ok have searched for this but no answers - am trying locally :)

One of the servers here has me logged in under a console session. If I go to the server I have the "only XX or or administrator can unlock this computer" or whatever that message really says.

If I ctrl-alt-delete - nothing happens, the screen stays exactly the same.

It's running on a KVM so I plugged a kb and mouse in directly - still the same.
The num lock light caps lock lights on the KB go on and off as they should - not a kb issue.

I can RDP into the server no problem and it is doing its role (MS Dynamics server) as per normal.

If I go to terminal services manager and try to log my own console session off, I get an error 31 "a device attached to the system is not functioning." I've googled that but found no real solution.

I've tried qwinsta command, logoff /session /servername - anything I try comes back with that same error 31 message.

It's not a huge issue but obvioulsy it's not a good situation to be in.

Any ideas please?

nedkelly
23-10-2009, 10:41 AM
anything been installed or uninstalled since the last time it work right?

FAB
23-10-2009, 10:43 AM
Nope - nothing at all. I've thought about that but nothign has changed on that server for a while.
I think I've simply walked away from it forgetting to log off, and now just can't get back in to it.

Speedy Gonzales
23-10-2009, 10:49 AM
This sound like the prob ? (http://support.microsoft.com/kb/951013/)

FAB
23-10-2009, 10:56 AM
Uh no not really. It's the local session that I'm having issues with.
I realise it will probably come down to having to reboot the server after hours, but just don't want the issue to appear again in the future, naturally.

Speedy Gonzales
23-10-2009, 10:58 AM
This then ? (http://office-outlook.com/outlook-forum/index.php/m/512698/)

FAB
23-10-2009, 11:02 AM
Yes and no - I checked out that post before and I'm loathed to kill my profile but if that's the only answer, so be it. Although I'm still also not wanting to do a force reboot.
The other thing with that post - I'm not seeing any grey/blue screens, just the normal "this computer is locked" message.
I'm not getting the "blank screen with blue background" that this guy is.
Am hopeful that there is a way to log me off the machine without having to reboot it.

CYaBro
23-10-2009, 11:14 AM
What about if you run a remote desktop connection but connect to the console session?
i.e. Start - Run - mstsc.exe /admin

That's for the new version of Remote Desktop, the old version had a different command, /console I think.

nedkelly
23-10-2009, 11:53 AM
try a usb keyboard?

inphinity
23-10-2009, 03:39 PM
Any event log errors? Any services not started that should be? RDP to the console session is a good suggestion above.

FAB
23-10-2009, 03:50 PM
Pretty sure not a KB issue, will try USB kb out of desperation though.
Event logs look fine - nothing that points to the problem at all. All services up and running - as I say, the server is running completely normally except for this one thing.

Interestingly, if I run mstsc.exe /v:servername /admin I get a blue screen (not BSOD) after putting in un and pw....haev to close out of it and leave the session running, which I guess is the problem after all.