PDA

View Full Version : Office 2007 style change ***!!##!!!



ecurb
08-09-2009, 10:39 AM
In Office 2007 for example I can do a heading then a double return before I start with more typing. The double return changes the heading to another style. If I do the double return v e ry s l o w l y then it doesn't change it. If I double return and the style changes I can get it back to normal by doing a backspace.

However this is all incredibly frustrating (even more so than office 2007 in general).

Can anyone offer a suggestion why a double return should change the style. I can't find a setting anywhere

Thanks in advance

linw
08-09-2009, 10:47 AM
Might be more productive to ask on a MS Word forum?

Erayd
08-09-2009, 10:49 AM
Might be more productive to ask on a MS Word forum?Might be, but we have some Office 2007 gurus on PF1 too - no harm in asking here.

Sweep
08-09-2009, 11:12 AM
In Word 2007 you could create a Quick style and save it as a default.

zcc
08-09-2009, 12:58 PM
Bottom line is if you are hitting TWO carriage returns (enters) after some text then the styles you are using are not right for you.
You need to edit the style either of the heading style or the normal style so that you get the space AUTOMATICALLY after or before the styles concerned.
Learn to edit your styles in word 2007 and you will become much more productive in word and your documents will look much better to idiots like me who cringe when they see hard coded (ie typed) carriage returns all over documents when they don't need to be there and clog up the document.
There are many ways to get to the style modify dialog in word.
Easy way is to:
1) right click on the heading text and select <Paragraph> in your case.
2) under <spacing> change the <before> or <after> values to what you want.
3) Click <OK>
4) right click on the same heading text again and select <styles>+<update XXXX to Match Selection> (where XXXX = the name of the style you are editing)
That will fix it for that one document.
For all documents read a textbook.
Good luck :thumbs:

ecurb
08-09-2009, 01:13 PM
With all due respect I believe the use of a computer/wordprocessor is to make life easier for the operator not to stop the purists from cringeing. I saw a similar response in a google search for double returns that said everything should be done with styles.
However if I am typing a letter in normal style and I have typed (or inserted) a date and want two blank lines before I start the address surely two carriage returns is the quickest/easiest thing to do rather than have a style to use for the date which leaves two blank lines after and then another style for the rest that types on consecutive lines. Surely I can enter my two returns without the font type and size from changing. It's not rocket science I would have thought. Please correct me if I'm wrong!!

Scouse
08-09-2009, 02:10 PM
Hi ecurb. Not offering any help here but just mentioning that when I double enter as you describe, no changes take place. Curious and watch with interest for an answer. I can understand your frustration. :illogical

somebody
08-09-2009, 03:43 PM
Can you create a file that exhibits this behaviour and upload it somewhere for us to look at? I've been using Word 2007 since January 2007 and have never come across what you describe.

ecurb
08-09-2009, 03:51 PM
Any polite suggestions of where to upload it

somebody
08-09-2009, 04:05 PM
Any polite suggestions of where to upload it

Upload it to http://imagef1.net.nz/ (rename the file so the extension is .jpg or similar, otherwise it'll reject it).

ecurb
08-09-2009, 04:27 PM
I've done as you suggest but can't open it myself.

See http://www.imagef1.net.nz/files/This_is_a_test.docx.jpg

somebody
08-09-2009, 04:40 PM
I can't replicate the problem.

If I do a backspace in your file, it doesn't do anything (other than delete the previous line).

If I use your file, but type a new heading, set it to "Heading 1", then hit return twice, it behaves as it should - the style stays the same, and I get two lines after the heading.

the_bogan
08-09-2009, 05:00 PM
in word options / proofing / autocorrect options / (AutoFormat) tab, is preserve styles ticked?

Sweep
08-09-2009, 05:02 PM
Two things to try. I can't get the same problem on my computer either.

1. Go start> all programs> Office> Office tools and run the diagnostic.

2. Search for the file normal.dotm and rename it to normal.oldm. When you start word next the normal.dotm will be recreated.

zcc
09-09-2009, 04:32 PM
If this is a recurring problem then style changes are needed else why complain here?
#13 and #14 are correct except I cant see diagnostics helping much, get rid of normal.dot (from all locations) and you should be back to ahhhhh normal.
Auto-correct can cause all sorts of problems if not used properly, it can be corrupted by macros under 2003, but under 2007 I thought it was supposed to be safe from such issues.
Good luck with word...

utopian201
09-09-2009, 04:48 PM
Might be more productive to ask on a MS Word forum?

And firefox questions on a firefox forum, intel CPU questions on an intel CPU forum, etc etc If so, what questions should we you ask here?