PDA

View Full Version : Turn off Office 2007 date autocomplete



FAB
27-08-2009, 12:54 PM
Morning all

I have a number of users here (50 or so) getting frustrated at Word and Outlook 2007 because of the date autocomplete.

The problem is that when they type in (for example), "28 July 2009" Word (or Outlook of course - Word editor) picks up the date format and changes it to 28 July 2009-08-27 if you press enter.

Of course the user can create an extra space at the end of the date to avoid this, but this is not the ideal solution and is not a natural thing to do.

I've seen some posts suggesting creating a macro to turn autocomplete on and off as you go, but to me this is not a long term solution either.

Has anyone else struck this? I feel like I should be able (for example) to create a new DWORD reg entry and apply it via the SBS2003 server group policy, so the change is not visible to the end user and they do not need to do anything...

Any suggestions gratefully appreciated!

Cheers

FAB
28-08-2009, 10:32 AM
So nobody has struck this before?

Yeah sorry, a little bump here....it's just one of those frustrating MS things where, when it happens, you wonder what on earth the developers were thinking!

It's like when you install XP fresh, it asks you what country you are in, then goes on to ask what language you want, what keyboard etc etc...I already told you -I'm in New Zealand, why do you insist on asking me all these region specific questions!

And then you get that bl**dy annoying language bar with the option of changing your language from NZ to US. Yeah, I need that ability quite regularly...not. To turn off the language bar is a hassle and it always seems to want to come back. Then another user logs on to the same machine and whammo! There's your language bar, taunting you..."US or NZ? US or NZ? Come on, make a choice here!"

And then you remove US as a language option and yet it still appears elsewhere. arrgghhhh!

Sorry, must be Friday, ranting is disabled from this point on.

somebody
28-08-2009, 11:00 AM
Try this: http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx?dg=microsoft.public.word.docmanagemen t&tid=468fffcc-ced1-4fc2-bb69-73a2a104d31f&cat=&lang=&cr=&sloc=&p=1

FAB
28-08-2009, 11:18 AM
Thanks for that - but had been there already.
There are no options for disabling date autocomplete in Word 2007 in the Autocorrect options. Out of desperation I disabled all of them but made no difference.

The only way I've succeeded so far is to run a macro but ideally I'd like to push something out through GPO so it works for every user on any machine.

FAB
01-09-2009, 12:54 PM
I'm making some progress on this myself, as I get spare time.

It looks like the best way (perhaps the only way?) to do this is to have a macro run:
Application.DisplayAutoCompleteTips = False
Which does in fact make this problem go away.

The thing is I want to include this macro in our org's template and have it run automatically.
However if I call the macro (I'm just testing it of course) Autoexec so it runs as soon as Word starts up, I get an error to say that the macro won't run because there are no documents open. Fair enough but not a solution.

So I created the same macro but called it Document_Open and Document_New and that also seems to work, but I have to run them manually to kick them off.

I'm not a macro kind of guy (not that I'm Micro!! haha) can someone suggest the easiest way for either of these scenarios to work?

The same problem as I said earlier is occuring in Outlook, however if I can get this sussed I can probably apply them to NormalEmail.dotm - or at least I hope that will work.

FAB
21-10-2009, 10:37 AM
I hate to bring this up again, but is no one else absoultely annoyed when you are in Outlook 2007, start typing a date and then it inserts today's date at the end when you press enter?
I'm finding it hard to believe this has not been fixed in some way in an SP...very slack, MS.
I'm starting to delpoy the macro around users and that fixes it for Word but does not work for Outlook.
Oh just to have an option "Autocomplete date yes/no" - easy!

Lurking
21-10-2009, 08:56 PM
Insert box, date and time and use English Australian and you will see 21 October 2009 in there, I do a lot of typing and MS does p*** one off a great deal.

Lurking.