PDA

View Full Version : Computers Can't find each other



justinsg
25-08-2009, 09:57 AM
Hi there,

My two windows xp computers cannot see each other on the same network (wireless N).

I have tried DHCP and maunal IPs neither work. It has worked on and off for the last few days. Windows can sometimes detect other computers but it is not constant.

The router's toolbox can ping each computer fine but they can't even ping each other.


Any help appreciated,
Justinsg

Blam
25-08-2009, 10:02 AM
Are there any firewalls on both PCs?

justinsg
25-08-2009, 10:06 AM
Are there any firewalls on both PCs?

Only windows ones but I have tried disabling them with no luck

Blam
25-08-2009, 10:48 AM
Download and run Winsockfix (http://www.softpedia.com/get/Tweak/Network-Tweak/WinSockFix.shtml) on both machines, then run it.

Are both PCs on the same workgroup?

In Services(run>services.msc) make sure that for both PCs these services are started and on automatic:

Computer Browser
Workstation
Server

"Network Location Awareness" make sure it says Started and Automatic.

Once that is done, copy each of these commands, then paste in command prompt(right click>paste) and hit enter after each.


netsh interface ip delete arpcache

ipconfig /flushdns

ipconfig /release

ipconfig /renew

ipconfig /registerdns

Could you also type in ipconfig /all in a new command prompt window then right click anywhere>copy>paste here. Do this for both PCs

Also make sure than in properties for your network connection that File and printer sharing and Client for Microsoft networks are installed

Cheers
Blam

Chilling_Silence
25-08-2009, 11:10 AM
How are they connect to the router? LAN Cable? USB?

justinsg
25-08-2009, 04:37 PM
Have run Winsockfix on both, checked services (were ok) and have checked the connection's components (Filesharing, Windows Network Client etc.) with no luck
@chillling_silence: the adapter is a Linksys USB Wireless N adapter (shown below)
Here are the cmd prompt results:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Justin>netsh interface ip delete arpcache
Ok.


C:\Documents and Settings\Justin>ipconfig /flushdns

Windows IP Configuration

Successfully flushed the DNS Resolver Cache.

C:\Documents and Settings\Justin>ipconfig /release

Windows IP Configuration


Ethernet adapter Wireless N:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :

C:\Documents and Settings\Justin>ipconfig /renew

Windows IP Configuration


Ethernet adapter Wireless N:

Connection-specific DNS Suffix . : WAG160N
IP Address. . . . . . . . . . . . : 192.168.1.101
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1

C:\Documents and Settings\Justin>ipconfig /registerdns

Windows IP Configuration

Registration of the DNS resource records for all adapters of this computer has b
een initiated. Any errors will be reported in the Event Viewer in 15 minutes..

C:\Documents and Settings\Justin>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : justin-dell
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : WAG160N

Ethernet adapter Wireless N:

Connection-specific DNS Suffix . : WAG160N
Description . . . . . . . . . . . : Linksys WUSB100 RangePlus Wireless USB Adapter #2
Physical Address. . . . . . . . . : 00-1E-E5-E2-52-5D
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.101
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 202.27.158.40
202.27.156.72
Lease Obtained. . . . . . . . . . : Tuesday, 25 August 2009 4:33:53 p.m.

Lease Expires . . . . . . . . . . : Wednesday, 26 August 2009 4:33:53 p.m.

wainuitech
25-08-2009, 05:13 PM
Just as a trial - turn off the wireless security for a short period - see if the computers can then talk / see one another consistantly.

If they do then theres something in the security settings causing the problem.