PDA

View Full Version : Win7 / ADSL router problem?



Tony
19-08-2009, 01:55 PM
I have a Dynalink RTA770 ADSL router. This works well and reliably under Vista, but I am finding under Windows 7 RC that sometimes Win7 can't "find the internet" unless I power the router off/on. This seems to happen most when the PC comes out of sleep, but not always. I never have this problem with Vista.

Ideas, anyone? One possibility is drivers/firmware, I guess.

Trev
19-08-2009, 02:19 PM
The only thing that could be causing a problem would be the ethernet driver. Basically your router runs separately from Windows.
:)

Tony
19-08-2009, 02:37 PM
Right - I'll check to see if there are updated drivers. I didn't expect it to be the router, as I realized it was a separate entity.

Thanks.

wainuitech
19-08-2009, 03:00 PM
See if this has any effect --

Open the control Panel - Make sure you are in Large icon mode.

Open network and sharing Center / On the top Left--- Change adapter Settings / Right click the adapter / Properties /Configure button /power Management Tab / Untick " allow the computer to turn off this device to save power" click OK.

SolMiester
19-08-2009, 03:21 PM
Remove IPv6 protocol for the NIC...you could also try the following, though this is mostly for proxy servers

1. In HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Lsa
If it doesn’t exist, create a DWORD value named LmCompatibilityLevel and set the value to 1 to use LM NTLM and NTLMv2 if is negotiated, this is Also it works establishing the value to 0, and 3 though for more safety the value using 3 though with old operating systems it will not work on having used obligatorily NTLMv2.

2. Reboot

Tony
19-08-2009, 03:33 PM
Open network and sharing Center / On the top Left--- Change adapter Settings / Right click the adapter / Properties /Configure button /power Management Tab / Untick " allow the computer to turn off this device to save power" click OK.Good thinking. I've now done that - it will be interesting to see if that fixes the problem.

Tony
19-08-2009, 03:35 PM
Remove IPv6 protocol for the NICInteresting... I'll see what wainuitech's suggestion does first, then try yours if that has no effect.

Blam
19-08-2009, 06:25 PM
I would agree with Solmeister....come across many "Limited Connectivity" and similar problems which disabling IPv6 solves.

Tony
25-08-2009, 12:01 PM
I would agree with Solmeister....come across many "Limited Connectivity" and similar problems which disabling IPv6 solves.Did we all know that if you want to set up a homegroup in Win7 you have to have IPV6 enabled? Not that I want to do it, but the requirement surprised me.

BTW changing the power managemnt on the adapter seemed to fix my original issue.

wainuitech
25-08-2009, 12:59 PM
good that its fixed -- interesting about home groups and IPV6. Had alook and it seems many people have found this out.


If you disable IPv6, you will loose HomeGroups, as Mr. Alexandriyski already mentioned.
So there will be no fix for this. "It's not a bug, it's by design" Quoted from Here (http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/4c0770bb-247a-46d6-8267-c3715410d98f) -- Seems theres a few "new" items people need to learn before suggesting "turn of ???" :D

Chilling_Silence
25-08-2009, 01:38 PM
I've never found a reason why it would need to be turned off, it shouldn't affect ipv4 networking ... ?

wratterus
25-08-2009, 01:45 PM
I have only ever had one issue with IPv6 'causing' internet connectivity issues, and it was probably Nortons causing it anyway. Also it was in XP, not Vista or Win7 where it is installed be default. Leave it on peoples! :p