PDA

View Full Version : USB HDD Booting problem



CYaBro
09-07-2009, 04:25 PM
Hey,

I have a problem/request in regards to booting from USB HDDs.

I have a few clients with HP ML110 G5 basic servers.
They have a few USB HDDs for system backups and this allows them to keep them offsite.
The problem is (and this seems to be a known problem with some HP servers) that the server always tries to boot off the USB HDD first and this of course fails and then the server stalls and doesn't try to boot off the internal HDD.
You can disable booting from the USB HDD in the BIOS but this seems to get reset when a new USB HDD is connected.

What I would like to do is put a boot loader/boot menu on all the USB HDDs that basically just has an option, or defaults to after 1 second or whatever, to boot from the internal HDD.

Should be possible?

Cheers
Chris

Speedy Gonzales
09-07-2009, 04:38 PM
Its probably changing them to the bootdisk in the BIOS. It can do the same thing with IDE or SATA hdd's. Not much you can do about it

Blam
09-07-2009, 05:07 PM
Why not set the boot order to HDD first and FDD second?

CYaBro
09-07-2009, 05:46 PM
Why not set the boot order to HDD first and FDD second?

I have changed the boot order and made the SATA HDD first and the USB HDD second and also disabled booting from the USB HDD in the BIOS.
This works great until the client swaps the USB HDD in the morning.
Then if the server is restarted, for whatever reason, the BIOS puts the USB HDD back to the first boot device and enables it if it was disabled.
I guess it is doing this because it sees a different USB device so assumes that you might want to boot from it.
(It doesn't remember the setting though even if you reconnect a USB HDD that you had disabled or changed the boot order for in the BIOS)

That's why I want to put a boot loader on all the USB HDDs so that even if it tries to boot off the USB the boot loader will point it back to the internal HDD.

I have seen this on some linux live CDs and others. You get a menu that displays the boot options and if you do nothing for 30 seconds it defaults to boot off the internal HDD.

pctek
09-07-2009, 09:12 PM
But the BIOS should remember the setting. Regardless of what USBs are connected or not.
I'd be seeing why it isn't retaining the setting.

gary67
09-07-2009, 09:59 PM
Is the mobo battery dying?

CYaBro
10-07-2009, 10:32 AM
But the BIOS should remember the setting. Regardless of what USBs are connected or not.
I'd be seeing why it isn't retaining the setting.

Doing some searching online and it appears to be a known problem with some HP Proliant servers, the ML110 G5 included, and HP don't seem to have done anything about it.


Is the mobo battery dying?

This is happening on brand new HP ML110 G5 servers so it's not the battery.

inphinity
10-07-2009, 11:12 AM
Same issue here, I just copied NTLDR and the boot.ini from the actual boot drive to the USB drives.
Other options, in.. I think it was an ML110 G4? If you set USB mode to Legacy it would not boot off USB devices, not sure if this applies for the G5.

This is an issue across multiple generations of ProLiant servers, as HP did not until recently officially support "permanently" attached USB hard drives and thus never saw an issue. Why there hasn't been a BIOS or firmware update to resolve it, though, I'm not sure.

CYaBro
10-07-2009, 11:29 AM
Same issue here, I just copied NTLDR and the boot.ini from the actual boot drive to the USB drives.
Other options, in.. I think it was an ML110 G4? If you set USB mode to Legacy it would not boot off USB devices, not sure if this applies for the G5.



Tried that thanks but still not working.
Do I need to edit the boot.ini file at all?

There is no option in the BIOS to make the USB mode Legacy :(

inphinity
10-07-2009, 11:47 AM
The partition on the usb drive needs to be flagged as active/bootable. It is possible, depending on the BIOS, that the boot.ini needs to be changed. What is possibly happening is that when it boots off a USB drive is it is reassigining controller IDs.

A typical boot.ini may look something like this:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003 for Small Business Server" /noexecute=optout /fastdetect
C:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /cmdcons

The bit we're interested in is:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

If the (presumably SATA? that you normally boot off) controller is no longer treated as controller 0 by the BIOS, then that's why this issue is occurring. I suspect this is the case but I'm yet to get anyone at HP who seems to have a clue about the problem. Anyway, if so you may need to alter this line to be, say,
multi(1)disk(0)rdisk(0)partition(1)\WINDOWS

CYaBro
10-07-2009, 01:29 PM
The partition on the usb drive needs to be flagged as active/bootable. It is possible, depending on the BIOS, that the boot.ini needs to be changed. What is possibly happening is that when it boots off a USB drive is it is reassigining controller IDs.

A typical boot.ini may look something like this:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003 for Small Business Server" /noexecute=optout /fastdetect
C:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /cmdcons

The bit we're interested in is:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

If the (presumably SATA? that you normally boot off) controller is no longer treated as controller 0 by the BIOS, then that's why this issue is occurring. I suspect this is the case but I'm yet to get anyone at HP who seems to have a clue about the problem. Anyway, if so you may need to alter this line to be, say,
multi(1)disk(0)rdisk(0)partition(1)\WINDOWS

Thanks for that!
It is working now :thumbs:

I had to make the partition active on each of the USB drives as you said in Disk Management then I copied over boot.ini and ntldr.
I then had to make the boot.ini like this:

multi(0)disk(0)rdisk(1)partition(1)\WINDOWS

The 1 was a 0 originally.