PDA

View Full Version : Boot sequence idiocy



linw
06-07-2009, 03:28 PM
Feel a bit stupid not being able to set a BIOS boot sequence:blush: Google has let me down as well. Story is I can't boot my P5Q Pro/win 7 combo with a USB drive plugged in. The problem seems to be the weird (to me!) boot sequence settings in the BIOS.

I have one SATA drive (SATA 1)and one DVD drive (SATA 2). The boot sequence screen sees these two plus a Removable device. Naturally, I want to set the first drive to DVD, the second to HDD and the third to removable. But it won't let me. Changing a device with the + or - key changes all three! So I lose control, basically. There is no combo that suits me. If I have the DVD first, the second HAS to be the removable device. This will be why I can't get win 7 to boot if a USB drive is there.

Am I missing something? Could someone who knows these mobos help?

TIA.

wainuitech
06-07-2009, 03:45 PM
Try this, go into the boot sequence, arrow keys to the 1st boot device, <Press Enter> arrow keys to the optical drive <Press Enter> optical drive should now be 1st boot.

Set HDD the same way - arrow to 2nd boot device<enter> select HDD <enter>

linw
06-07-2009, 04:31 PM
Well, I'll be!! In my defence the screen and book don't indicate an enter key is an option!

So, finally got DVD, HDD, Disabled in order. Hooked up USB and rebooted. Guess what - still wouldn't boot!

Never mind. Not really crucial for now but bit annoying.

Thanks, WT. As always, spot on!

linw
06-07-2009, 04:50 PM
Did some more searching. Saw where someone 'solved' this by changing ports. Tried it and it worked. Go figure.

Tried it back in the original port - still worked. Those USB ports are mysterious things.

wainuitech
06-07-2009, 05:02 PM
Found out by mistake about the enter key options.

Does it boot without the USB drive attached ?

If it does give this a crack -- My Board is a P5QL-E

In the BIOS - main Screen /Advanced / USB Configuration /legacy USB Support--- Set to Disabled ( default is Auto).

Heres what the "Manual says" ---Allows you to enable or disable the support for legacy USB devices. Setting to [Auto] allows the system to detect the presence at startup. If detected, the USB Controller legacy mode is Enabled. If No USB device is detected, the Legacy USB Support is disabled. Configuration options:[Disabled] [Enabled] [Auto].

linw
06-07-2009, 08:24 PM
Yep, has been booting fine without the drive attached. As an experiment, I turned off legacy support (was auto) and it didn't boot (no drive attached). I then realised I had a USB scanner turned on. Turned it off and it still wouldn't boot! Turned legacy support to auto and it booted.

I'm a bit confused at the moment!! Think I will have a cup of tea and a lie down:D

There seem to be a few interacting variables at play which makes it VERY hard to come to any conclusions.

Not to worry, as it isn't a big problem at the moment but it could be for people wanting to leave USB devices attached.