PDA

View Full Version : Word 2007 Autocorrect settings



Tony
22-06-2009, 09:00 AM
I've found that if the document language is set to other than English(United States), the full default list of autocorrect entries is not available - just things like (c) for copyright etc. This means that "teh" will not get corrected to "the" for instance. The problem with having the language set to US is that then you get US spelling and grammar rules as well (color/colour).

Does anyone know if it is possible to get a list of autocorrections in NZ English (or Aussie or UK) and have them available?

the_bogan
22-06-2009, 10:42 AM
In proofing options, do you have the 'suggest from main dictionary only' unchecked?

Tony
22-06-2009, 12:43 PM
In proofing options, do you have the 'suggest from main dictionary only' unchecked?Yes, it is unchecked. Reading the help, it seems to me that is how I would want it.

Speedy Gonzales
22-06-2009, 01:53 PM
Just change whatever to the way you want them to be spelt

Tony
22-06-2009, 02:03 PM
Just change whatever to the way you want them to be speltI realize you can add to/edit the list. What I have found is that the original list only appears if you have the language set to US English, and I wouldn't want to be having to build the whole lot from scratch.
BTW this isn't really for me - I don't use it much. It is for my SeniorNet group, who found the discrepancy between students' home machines and those in the clubrooms.

ronyville
22-06-2009, 02:06 PM
could it be anything to do with the regional settings as well? most are not set to NZ by default.

Speedy Gonzales
22-06-2009, 02:11 PM
True change it to NZ under regional settings

Tony
22-06-2009, 02:19 PM
Presuming you mean Regional Settings in control panel, they are all set to English(new Zealand).

Speedy Gonzales
22-06-2009, 02:25 PM
Office button top left / word options / popular / language settings / primary editing language. Change to English (NZ) ?

Tony
22-06-2009, 02:30 PM
Office button top left / word options / popular / language settings / primary editing language. Change to English (NZ) ?That is exactly what causes the problem. If that setting is US english it is all OK. Anything else and the word list disappears.

Saucy
22-06-2009, 09:44 PM
Does anyone know if it is possible to get a list of autocorrections in NZ English (or Aussie or UK) and have them available?

I dislike autocorrect so I hadn't noticed this, but I couldn't resist figuring it out.

From the search results I chose the official support one here:
http://support.microsoft.com/kb/926927

That gave me the idea that all you need to do is rename the US autocorrect list to the country code it's using for NZ, which I checked here:
http://support.microsoft.com/kb/221435/

But that didn't quite work, because when I looked in the folder, there was no NZ country code file there. Then I noticed in Word, in the heading of the autocorrect settings, it seems to using the Australia autocorrect list. Bingo, because there was a file in the directory with the Australia country code. Tried it, and it works.

Enough about my journey of discovery. Here are the steps you need to follow to get the result you want.

You need to have both English (US) and English (NZ) installed. I think this will happen automatically if you install Word with NZ regional settings so I won't go into how to check that. If the next steps don't work we'll come back to this.

Get a Windows Explorer window open, and get to:
C:\Documents and Settings\your username\Application Data\Microsoft\Office

There you should see MSO1033 and MSO3081. MSO1033 is the US autocorrect list that you want, notice it's a much bigger file. MSO3081 is the autocorrect file it's using if you have English (NZ) set as your language.

So, make sure you have quite Word. Now, rename MSO3081.acl to MSO3081.old. Then, copy and paste MSO1033.acl to make a second copy of it in the folder.

Now, rename the second copy which is probably called MSO1033 - Copy.acl, to just MSO3081.acl.

You're done. Open Word, and you should find it is using the full list of autocorrects from the US list.

Extra help if needed ..... If the file extensions are not showing, you need to hit Alt / Tools menu / Folder Options / View tab / uncheck Hide extensions for known file types.

Rob99
22-06-2009, 10:33 PM
This will give you all the US autocorrect settings and keep your language NZ.

C:\Documents and Settings\Saucy[username][/COLOR]\Application Data\Microsoft\Office

You will see some .acl files, MSO1033.acl is the US version.

Select all the acl files and back them up.

Copy the MSO1033.acl to MSOXXXX.acl

The XXXX is the other acl files in the same folder, if you can guess the NZ first time cool, I didnt so I did them all and it worked.




Edit: I think this is what Saucy said, only their post was too long for me to read...LOL




.

Tony
22-06-2009, 10:49 PM
I dislike autocorrect so I hadn't noticed this, but I couldn't resist figuring it out.

From the search results I chose the official support one here:
http://support.microsoft.com/kb/926927

That gave me the idea that all you need to do is rename the US autocorrect list to the country code it's using for NZ, which I checked here:
http://support.microsoft.com/kb/221435/

etc. etc.
Brilliant! That sorted it. I'd actually already come across the first support reference, but couldn't quite get it to apply to my situation.
Of course the question now is - why do we have to do all this? I can't believe even Microsoft would only supply autocorrect for US English. :confused:

Thanks very much for doing the investigation (and knowing where to look)!

BTW the file paths etc you gave were all XP, right? They are actually different in Vista, but I managed to get there.
:thumbs:

Saucy
22-06-2009, 11:03 PM
Of course the question now is - why do we have to do all this? I can't believe even Microsoft would only supply autocorrect for US English. :confused:

Thanks very much for doing the investigation (and knowing where to look)!

BTW the file paths etc you gave were all XP, right? They are actually different in Vista, but I managed to get there.
:thumbs:

Glad we could help. Rob99 had the same idea too.

For the why, who knows! My guess is there might be some "US spellings" in the US autocorrect, and the developers were unsure whether the autocorrect was right for other countries.

I'm using Vista too on this PC and the paths worked for me, interesting they were different for you. Another mystery. :p

Tony
22-06-2009, 11:16 PM
The path I needed was:

Desktop\USERNAME\AppData\Roaming\Microsoft\Office

???