Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Unknown Device wratterus's Avatar
    Join Date
    Apr 2007
    Location
    Top of the South
    Posts
    11,469

    Talking Kill algae in water cooling system

    Got a thermaltake water cooling system, had a fin break off the pump a while back and the only way to sort out all the little bits of plastic that ended up through the system was a high pressure flush out.

    Obvoiusly this had to be done with water, and consequently since I've filled it up with the antifreeze stuff again, its been slowly growing algae and other interesting looking plants and creatures.

    Does anyone know of something I could use that would kill off any living things floating around the system without damaging any of the tubing or the pump?

    Thanks.

    PS - avoiding corrosion of the CPU water block would also be preferable
    Last edited by wratterus; 11-11-2008 at 01:20 PM.
    Microsoft: "You've got questions. We've got dancing paperclips."

  2. #2
    Old guy
    Join Date
    Dec 2004
    Posts
    1,218

    Default Re: Kill algae in water cooling system

    Any aquarium stockist should have some product that will do the job safely. There are plenty of plastic parts & tubing, not to mention the fish, in an aquarium set up where algae can be a problem.

    A bit of chlorine bleach would also kill algae and as it obviously does not melt the plastic container it is sold in should be ok.

  3. #3
    Senior Member Q man's Avatar
    Join Date
    Oct 2008
    Location
    pukekohe
    Posts
    187

    Default Re: Kill algae in water cooling system

    Thanks for bringing this up.

    Just installed thermaltake 735i and used there coolant/antifreeze.

    I'm not looking forward to having a small algae farm growing next to my new graphics cards.
    How long did it take to start growing plants? Please post back if the bleach works.

  4. #4
    Senior Member Thebananamonkey's Avatar
    Join Date
    Dec 2007
    Location
    Wellington
    Posts
    1,677

    Default Re: Kill algae in water cooling system

    Do you use tap water? Or evian/equivalent?

  5. #5
    Unknown Device wratterus's Avatar
    Join Date
    Apr 2007
    Location
    Top of the South
    Posts
    11,469

    Default Re: Kill algae in water cooling system

    To clean it out I used tap (bore) water.

    I had no problems at all until I flushed it out, (about a year). it took about 2 months to start growing after that.

    I'll try a few things and post back.
    Microsoft: "You've got questions. We've got dancing paperclips."

  6. #6
    Senior Member Thebananamonkey's Avatar
    Join Date
    Dec 2007
    Location
    Wellington
    Posts
    1,677

    Default Re: Kill algae in water cooling system

    Quote Originally Posted by wratterus View Post
    To clean it out I used tap (bore) water.

    I had no problems at all until I flushed it out, (about a year). it took about 2 months to start growing after that.

    I'll try a few things and post back.
    Try flushing it using purified, and then using that to run it.

    A small amount of bleach may do something, but I'd check in the NZ OC Forum if I were you. They're probably the people to talk to about this stuff.

  7. #7
    Senior Member Q man's Avatar
    Join Date
    Oct 2008
    Location
    pukekohe
    Posts
    187

    Default Re: Kill algae in water cooling system

    Thanks Watterus that would be great,

    I'll keep using there coolant see how that goes.

    Would UV light kill any Bugs? or just look "cool"
    E8400 @ 4.6Ghz W/C
    4G Ram?
    2x 4850 / 750w
    EP45-ds4P
    Armor Case

  8. #8
    Unknown Device wratterus's Avatar
    Join Date
    Apr 2007
    Location
    Top of the South
    Posts
    11,469

    Default Re: Kill algae in water cooling system

    Pretty sure light encourages growth doens't it? But it looks awesome!
    Microsoft: "You've got questions. We've got dancing paperclips."

  9. #9
    VoidMaster
    Join Date
    Dec 2004
    Posts
    4,999

    Default Re: Kill algae in water cooling system

    Toilet Duck.

  10. #10
    Senior Member Q man's Avatar
    Join Date
    Oct 2008
    Location
    pukekohe
    Posts
    187

    Default Re: Kill algae in water cooling system

    Bugger I've only got Harpic white and shine.
    E8400 @ 4.6Ghz W/C
    4G Ram?
    2x 4850 / 750w
    EP45-ds4P
    Armor Case

Similar Threads

  1. Water cooling
    By bluezone in forum PressF1
    Replies: 11
    Last Post: 15-01-2008, 06:32 PM
  2. Water Cooling
    By JUST INSANE in forum PressF1
    Replies: 14
    Last Post: 12-10-2007, 10:49 PM
  3. Water Cooling
    By The_End_Of_Reality in forum PressF1
    Replies: 23
    Last Post: 11-11-2005, 05:24 AM
  4. My Water Cooling Solution
    By noone in forum PressF1
    Replies: 8
    Last Post: 08-01-2005, 01:31 PM
  5. Water Cooling
    By ApeNz in forum PressF1
    Replies: 13
    Last Post: 29-10-2004, 11:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •