Results 1 to 10 of 10
  1. #1
    Junior Member
    Join Date
    May 2007
    Posts
    5

    Default DirectX Sound Problem

    Hi
    New to this & computers do my head in so bear with me please...

    For no apparent reason, my pc has stopped issuing any sound from the speakers. Everything is connected properly but I can't hear anything online, via itunes or Windows Media Player. The pc is as it came out of the box (apart from updated ram) so no replacement sound or video cards. I've ran the diagnostics and DirectX is showing the following fault message for Sound1 & 2 :
    DirectSound test results: Failure at step 19 (user verification of software) : HRESULT = 0x00000000 (error code)

    Nothing is coming out of
    USB Audio CODEC
    Microsoft Synthesizer
    Microsoft MIDI Mapper (Emulated)
    Microsoft GS Wavetable SW Synth (Emulated)

    Though the Realtek AC'97 Audio appears to be OK...

    I was able to get sound until a couple of weeks ago but I don't recall doing anything special that might have affected anything (other than routine Norton cleanups). I am getting a popup box on start up - pchnotify.exe not working - that may have appeared around the same time..

    I have seen a similar thread on here a while ago but that was something to do with a Creative soundcard. There are no yellow or red exclamations when I go into Device Manager.

    Any help would be very greatly appreciated.

    Cheers

  2. #2
    Member
    Join Date
    Dec 2004
    Location
    NZ
    Posts
    43,119

    Default Re: DirectX Sound Problem

    This

    May fix the pchnotify prob.

    You may have to reinstall the soundcard drivers. Do u know what the model is of this HP PC??

    But if the sound is working, are u sure noone has muted the sound??

    If youre using XP go to control panel \ sounds and audio devices \ volume tab \advanced button.

    And check that mute all \ mute isnt ticked under volume control, and wave.

  3. #3
    Junior Member
    Join Date
    May 2007
    Posts
    5

    Default Re: DirectX Sound Problem

    Thanks for coming back to me !

    The pc is a HP A509.UK 2.6Ghz.

    I've rechecked to make sure but mute is definitely not ticked on any option...

    Cheers

  4. #4
    Member
    Join Date
    Dec 2004
    Location
    NZ
    Posts
    43,119

    Default Re: DirectX Sound Problem

    You could try reinstalling the Audio drivers

    The top download.

    See if that fixes it.

  5. #5
    Junior Member
    Join Date
    May 2007
    Posts
    5

    Default Re: DirectX Sound Problem

    I'll give that a go though the Realtek '97 Audio was already working OK. It's the other stuff that's on the blink...

    Cheers

  6. #6
    Junior Member
    Join Date
    May 2007
    Posts
    5

    Default Re: DirectX Sound Problem

    Reloading / upgrading Realtek hasn't made the rest of it work - still no sound from iTunes or Media Player...

    On the upside, I've fixed the PCH problem on start up

  7. #7
    Member
    Join Date
    Dec 2004
    Location
    NZ
    Posts
    43,119

    Default Re: DirectX Sound Problem

    At least 1 thing has been fixed!

    You sure the speaker cables are plugged into line out on the soundcard?

  8. #8
    Junior Member
    Join Date
    May 2007
    Posts
    9

    Default Re: DirectX Sound Problem

    Hello, I am not sure that it might be directx, there are a lot of error message with itunes and realtek sound, I had a sound problem with realtek HD sound.
    to fix this I had to download and reinstall quicktime. (completed this on 7 pc's and notebooks over the last couple of months.)
    Hope this helps
    WayneH

  9. #9
    Member
    Join Date
    Dec 2004
    Location
    NZ
    Posts
    43,119

    Default Re: DirectX Sound Problem

    There was also a patch for HD sound or something on the MS site.

    A patch to fix a patch. Coz the patch MS released caused probs, and they released another patch to fix it.

  10. #10
    Junior Member
    Join Date
    May 2007
    Posts
    5

    Default Re: DirectX Sound Problem

    Hi,

    The Realtek is fine - the problem appears to be with the std default USB Audio CODEC. Just on the offchance, I have just swapped the defaults over and - hey presto ! - using Realtek, I now have sound again... I'll never understand computers

    Thanks for the help & suggestions !

Similar Threads

  1. Sound/DirectX problems... ugh.
    By X6488 in forum PressF1
    Replies: 4
    Last Post: 11-08-2008, 12:41 PM
  2. directx sound driver missing.
    By billbones in forum PressF1
    Replies: 9
    Last Post: 20-04-2007, 11:33 AM
  3. DirectX problem Help!
    By Dancso666 in forum PressF1
    Replies: 10
    Last Post: 04-07-2006, 08:16 AM
  4. DirectX 9 problem (i think)
    By Tonnes in forum PressF1
    Replies: 13
    Last Post: 19-01-2005, 04:02 PM
  5. DirectX 9.0 problem
    By tonnes101 in forum PressF1
    Replies: 6
    Last Post: 08-08-2004, 04:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •