PDA

View Full Version : OpenDNS settings for Technicolor TG589vn



sahilcc7
11-09-2013, 06:05 PM
Just got this router from Telecom to go to VDSL2, but I can't seem to configure the OpenDNS settings for it. I have tried entering settings in Dynamic DNS service, and DHCPv4 Pool LAN_Private.
OpenDNS won't work for some reason..

Any ideas? Thanks in advance...

sahilcc7
11-09-2013, 08:51 PM
Never mind - this worked : http://forums.whirlpool.net.au/archive/1877528

Weird how you have to go through command prompt to do it..

Agent_24
11-09-2013, 08:51 PM
Dynamic DNS is for services like No-IP

You might be able to do it through the telnet interface but I've never tried

Ichthus
13-09-2013, 07:31 AM
Have exactly the same challenge sahilcc7.

I also found similar links to the one you posted.

Would appreciate it if you could post the command lines you used as I struck a couple of concerns:
1. dns server route list - did not return a list of servers (only had add and flush options)
2. when used intf=Internet for adding OpenDNS servers the commend errored - as I did not get the list from the (1) I can not check the correct interface.

No looking for a CLI tutorial here (google for that) but seeing what worked for you would help me.

Cheers, ian

sahilcc7
13-09-2013, 04:58 PM
Not all the steps worked for me either.

1) Telnet 192.168.1.254 (whatever your router IP is)

2) Enter password/user

3) dns server route list didn't work for me, so I proceeded to the next step.

4) dns server route add dns=208.67.220.220 metric=1 intf=Internet (change the IP to whatever dns you are using)

5) dns server route add dns=203.50.2.71 metric=2 intf=Internet (add second one)

6) config saveall

7) system reboot

Then wait for the router to restart and DNS should be working.

Just make sure you've enabled telnet in add/remove features.

Ichthus
13-09-2013, 06:59 PM
Thanks for the prompt reply, other than needing to use PPPoE (see below) OpenDNS now up and running.

My command line in case it helps anyone else searching this topic:
{Administrator}=>dns server route add dns=208.67.222.222 metric=1 intf=Internet

Invalid interface name specified.
Bad value for parameter 'intf Internet'
Illegal option.
Unknown command.

{Administrator}=>dns server route add dns=208.67.222.222 metric=1 intf=PPPoE
{Administrator}=>dns server route add dns=208.67.220.220 metric=2 intf=PPPoE
{Administrator}=>config saveall
{Administrator}=>system reboot

Might do some further investigation into why I can't list the severs....;)