PDA

View Full Version : Linux fought Partition Magic - Linux won.



20-10-2001, 04:47 PM
Hi,
System specs: AMD Athlon 1200MHz
Windows Me
30Gig IDE HD

Problem: Used Partition Magic 7.0 to partition my hard drive into the following partitions: 5Gig Windows, 256mb winswap, 11Gig windata, 1Gig Linux Root, 256mb linuxswap, 11Gig linuxdata.

Note: some are primary, and some are logical partitions hence total no. >4.

Installed Redhat Linux 7.1 from bootable cd - specified which partitions for linux to use using druid. Linux didn't like this at all. Installed OK, but big probs on boot.

Reinstalled linux letting lnux do what it liked in terms of partitions.
Sweet-as, linux runs fine, also dual boots to windows fine. Can read/write to disc from both OSes.

But... PM nolonger can read the drive - 'Init. failed: Error 117. Partitions Drive letter cannot be identified.'

So I booted from the PM rescue discs - only solution offered by PM is to reformat entire drive. - Not An Option!

So, how do I play with my partitions? I still do not know linux well enough to do it from there.

Also, where can I mount my fat32 windata partition in linux so as to access my windows files?

Hope someone can help.
G P

20-10-2001, 05:16 PM
What type of partition did you use for linux?

PM can probably only read ext2 partitions and I think RH7.1 uses ext3.

You can mount a partition to any folder you like (if it already contains files they will be hidden until you unmount). You can see where partitions are currently mounted by using using mount command (no arguments).

So you could use for example /mnt/windata.

You will need to figure out the name of your windata partition. Your main windows partition will be /dev/hda1.

Normal partitions are hda1 thru hda4. Extended partitons are hda5 up. You will be able to see the order in dos FDISK.

To mount it at boot you will need to edit /etc/fstab.
Just copy and paste the line for your first windows partiton and edit it so it points to eg /dev/hda2 and mounts to /mnt/windata.

To test mounting it use the command: mount /mnt/windata

20-10-2001, 11:10 PM
What install option did you choose? Best is 'expert'. If you choose 'workstation' Linux tries to do it's own partitioning even though you have prepared the disk with PMagic - result = a mess!!

To mount the windows partition (assuming it is first primary partition on first drive):

mount -t vfat /dev/hda1 /mnt/win

YOu need to make the folder /mnt/win first.

John