PDA

View Full Version : DMA Troublez (still)



14-10-2001, 03:54 PM
I have recently upgraded to a 10GB Quantum Fireball HDD. It supports UltraDMA 33 but I cannot seem to enable DMA. Even ticking the DMA box in the Device Manager under Disk Drives does not work, when I restart the system for the changes to take effect it is unticked again. Is there another way to enable it? My motherboard supports up to DMA 33 transfers so why does it not work. I have an older 500MB HDD on my Secondary IDE channel as Slave with my CDROM as master. The 10GB Quantum is the only drive on my Primary IDE channel set as master. Could it be that in my BIOS it is running in MODE NORMAL and not LBA. I am currently running a Pentium 2-266MMX with 64MB SDRAM on a Microstar MS6126 motherboard. Any suggestions would be appreciated.

14-10-2001, 05:07 PM
Are you POSITIVE your motherboard supports ata33. Otherwise try getting some new drivers for your motherboard.

14-10-2001, 06:45 PM
You have to have the right type of cable as well. With some mother boards you have to run a seperate utility to enable the DMA

14-10-2001, 06:55 PM
What's the difference between DMA and ATA are we all talking about the same thing.

14-10-2001, 10:01 PM
You need to go back a step and check whether your BIOS is in fact detecting your hard drive as UDMA 33 capable.
(ATA 33 and UDMA 33 are one and the same thing.)
You can do this by looking at the screen during boot-up, pressing the pause key if necessary to halt on the screen that has the rectangular box with all the details in it. If you dont see that the IDE primary drive is marked as UDMA, then go into BIOS setup, and if it's AWARD go into Integrated Peripherals and check that IDE Primary Master UDMA is set to Auto.

The manual for your M-6126 motherboard does say that UDMA 33 is supported. If your BIOS is AMI, then I'm not so sure as the AMI BIOS part of the manual does not mention UDMA, only mode 4, PIO.

Cheers

14-10-2001, 10:05 PM
I'll sat it again. If you don't have an ata cable on the hardrive the bios will not detect that it is UDMA

15-10-2001, 05:24 PM
do you have a sound blaster sound card at all. in particular SB16 emulation.

if so you may need to disable the SB16 emulation

;-)