PDA

View Full Version : Windows 7 cannot access secured XP shared folders



gretag34
08-07-2011, 10:34 PM
Hi
I have an XP machine and a Windows 7 machine. Simple file sharing is off on the xp machine.

On my XP machine, I have some folders which anyone can access and some which I only want some users to access.

On the anyone can access folders the permissions are:
sharing tab permissions: "Everyone" has read;
security tab permissions: "Everyone" has Read & Execute/List Folder contents/Read

I can access this one fine from windows 7.

However for the secured folders (which not everyone should access), the settings are:
sharing tab permissions: "Everyone" has read;
security tab permissions: "Users" has Read & Execute/List Folder contents/Read

I was hoping that when I access this private drive, Windows 7 should prompt me with the XP machine's username and password.

However it says "Windows cannot access \\XPComputer\private
You do not have the permission to access \\XPComputer\private. Contact your network administrator to request access".
When I add everyone to the security tab permissions, it works fine, but of course I want it to be password protected, not free for all.
How do I make it prompt me for a password?

wainuitech
08-07-2011, 10:50 PM
From memory you cant if its XP Home only in XP Professional. In Home its all or nothing on the shared folder.

You can get around that by using some third party software.

The reason it can be done the other way around, in Windows 7 is because W7's sharing / permissions is based on server 2003, which allows different users different rights.

The password feature was in Win98, but for some reason MS decided to remove it when they came out with XP Home, but is available in XP Pro which would generally be used in a business environment.

fred_fish
08-07-2011, 11:06 PM
You can still turn off simple sharing and have user level sharing on Home, just not domain authentication.

Sounds like XP is set up right and it is a 7 problem.
It's probably trying to be helpful and make it "easy" for you...
Make sure Homegroup is turned off.
Try mapping a network drive to the share, in XP it gave an option to supply alternate credentials in the 'wizard', don't know about 7.

wainuitech
08-07-2011, 11:22 PM
Just found an old article from PCMag 2003 - never tried it, but also many people have tried to password protect XP home and failed.

Article from PCMag:

Probably the most frustrating omission in Microsoft Windows XP Home Edition is that there's no way to add a password to a shared folder, which means you can't restrict individual access to the folder. Anyone with a valid user name and password can access every share on the PC. We can't fix that problem, but we have found a simple workaround that lets you prevent outsiders from accessing your shared folders.

Here's the idea: If you don't have a valid user name and password, you can access a shared folder only as a Guest. Password-protect the Guest account and you thwart unwanted access. Here's how—in six easy steps:
•Log on as Administrator.
•Go to Settings | Control Panel | User Accounts, and click on Guest Account to make sure it is turned on.
•Go to Start | Run, type cmd, and hit Enter.
•At the prompt, type Net user guest password and hit Enter.
•Go back to User Accounts and click on the Guest account.
•Note that you can now add a password (see the screen). Do so and reboot.
From now on, any attempt to log on to shared folders from the Guest account will require the Guest password for access—even if the Guest account is turned off!





original Article (http://www.pcmag.com/article2/0,2817,803367,00.asp)

gretag34
08-07-2011, 11:57 PM
It is XP professional.

Hhm, thanks for the suggestion of mapping a drive; it gave me the option of connecting using different credentials, but it said
"The network folder specified is currently mapped using a different username and password.
To connect using a different user name and password, first disconnect any existing mappings to this network share".

Except I don't have any other mappings and I was using my XP username and password.

Any other suggestions? I'm sure I have seen the windows 7 username and password prompt when accessing a secured share before...

edit: I've also left the homegroup on windows 7.

fred_fish
09-07-2011, 04:55 AM
Just found an old article from PCMag 2003
That info holds true while Simple Sharing is turned on. More options are available when it's turned off.


"The network folder specified is currently mapped using a different username and password.
To connect using a different user name and password, first disconnect any existing mappings to this network share".

Except I don't have any other mappings and I was using my XP username and password.
Windows is a bit stupid like that.
Try rebooting and then mapping a drive before trying any other connections.

berryb
09-07-2011, 08:55 PM
On the XP box create a user account with the same name and password as on Win 7 box and give it a go.

gretag34
11-07-2011, 10:08 AM
On the XP box create a user account with the same name and password as on Win 7 box and give it a go.

The windows 7 computer isn't owned by me, so I don't want to start adding my own accounts to it...
Surely what I am trying to do isn't impossible right?

wainuitech
11-07-2011, 12:21 PM
Its not the Windows 7 computer thats causing your problem, its XP PRO.

Have a read of This article (http://support.microsoft.com/kb/307874) The problem you are having, and its stated by the original post - "When I add everyone to the security tab permissions, it works fine," you have to add the users you want in the permissions box.

Once you have done that, the users you select will have access or not as allowed. Basically you have to add in user / Groups to the XP machine -- bit more indepth (http://www.practicallynetworked.com/sharing/xp_filesharing/index.htm) - shows how.

Also have a read of This here (http://www.computerhope.com/forum/index.php?topic=20444.0) - may help a bit more

So to answer your question :) " Surely what I am trying to do isn't impossible right? "

yes it can be done, you just have to do all the steps not bits of them ;)

gretag34
11-07-2011, 02:07 PM
Maybe its better if I name the accounts:

I have the correct permissions for the particular user "Alice" on the XP computer. In my original post, "Users" have (Read & Execute/List Folder contents/Read), and Users includes Alice. XP has an account only for Alice, not Bob. Bob is not allowed to access this folder.

Windows 7 does not have an Alice account, but a Bob account. When Alice is at Bob's computer (using Bob's account), she tries to access her shared folder on the XP machine.

As Bob is not allowed to access Alice's folder on the XP computer, shouldn't it pop up with a password prompt where Alice can enter her details? Instead it just says You do not have permissions etc. Presumably because Windows 7 is sending XP Bob's credentials.

I read those links and I've made sure to disable the guest account as per your last link. Only Alice should access this folder, not Guest.

I think it will work if I add either Bob's account to XP and give him permissions, or add Alice her own account on Windows 7, but neither of those are possible.

wainuitech
11-07-2011, 02:50 PM
As Bob is not allowed to access Alice's folder on the XP computer, shouldn't it pop up with a password prompt where Alice can enter her details? In XP the password protect folders was removed (it was available in Win98) Why they did this is damn stupid AFAIK - while the permissions can be applied, if the previous articles dont work, then I dont know how to get that prompt,its not W7, its XP causing the problems.

Some of the time XP pro is on a LAN, that also runs through a server, the shares and permissions are setup within the server, where the files are located.

While this is a side subject -- There is one way to achieve what you want -- Do you happen to have a old Computer sitting about doing nothing ?

If so you could set it up as a NAS (network attached storage) - install Amahi Home Server (http://www.amahi.org/) - Its free, put all your documents, folders you want to share on that - good for backup as well.

Then you could set the permissions to who ever you want, and it prompts for user names and passwords.

The attachment shows what happens when my Wifes PC tries to connect to the Amahi Home Server - she doesn't have an account on it (yet), but if I enter in my details, its straight in exactly like my own PC ( both of us have W7) The software is Linux based server software.

gretag34
11-07-2011, 03:19 PM
Hi, yes! that is the exact dialog I am expecting! I would then enter Alice's details and it all should just work.
You would expect that dialog to come up in my situation right?

If the pros on this board can't figure it out, I know I'm not going crazy!

wainuitech
11-07-2011, 04:23 PM
Theres bound to be ways of doing it, just have to play around a bit.

Password prompting Via a server is easy, its designed to do that function.

I did come across This article (http://www.ehow.com/how_2196195_password-protect-folder-windows-xp.html) - dont have any XP computers going at the moment, so cant test it - no idea if it will do what you want or not.

gretag34
12-07-2011, 10:25 AM
ok, I have done some more snooping, it turns out Windows 7 is using the guest account to try access the share. As guest is disabled on the XP machine (for security reasons), it is failing.
How do I get windows 7 to not use guest, but ask the user which account to use (ie via a prompt)?
When I use map drive with different credentials, I can put in the correct details, but it still gives me the same error.
I just need to find out how to make windows 7 NOT use the guest account,
(perhaps as easy as disabling guest account?)

I'll post the fix here once I find it.

wainuitech
12-07-2011, 11:50 AM
Windows 7 shouldn't be using the guest account - maybe someone has fiddled with the sharing and made it that way - it "should" be using the user logged in.

Just a thought , when W7 was setup to sharing or join a network, if it was set to Homegroup, or public sharing then that may be the reason for guest being used.

You can disable password protected sharing in W7, but I dont think thats the problem, to do that ,click start, type in sharing - select manage advanced sharing settings, scroll down, select turn off password protected sharing.

berryb
13-07-2011, 11:11 AM
"When I use map drive with different credentials, I can put in the correct details, but it still gives me the same error."

When entering username from Win7 use XPcomputername\username eg xpoffice\gretag34

I haven't read all the posts but this may help.

gretag34
15-07-2011, 09:51 AM
cool, i'll try that, but I dont actually want the drive mapped. Since other people use the windows 7 computer, only I want to access this folder.

Anyway, I have narrowed it down to one of these (or a combination of these three) settings in the security options in group policy:
Guest Account status
Network access: Let Everyone permissions apply to anonymous
Network access: Sharing and security model for local accounts (either local users authenticate as themselves, or local users authenticate as guest)

The problem is that when I changed those settings before, they werent applying immediately so it appeared they had no effect. Even when I force an update (with gpupdate /force), sometimes it still has no effect.

If you're interested, the two outcomes I have found are:
1.
I can click on the gretag34 computer in Network and it will list the folders
Shared folders with "everyone" access do not require a prompt
Shared folders without everyone access give me the "Access denied" message

2.
I click on the gretag34 computer in Network and it will ask me for a password (even to just list the folders!)
If I logon using Alice (the xp account), I can list all the folders and access ALL shared folders as Alice is "everyone" and has authenticated with the protected folder.

Neither of the above situations are what I want, but I'm getting closer!